Can't return to INFUSE once in metadata search function

Like the title says. tvOS 14. INFUSE 6.5.
Pressing “MENU” closes INFUSE.
Apparently this only happens, when trying to edit the metadata of a TV series season cover.

Just to cover all bases, have you tried restarting the ATV from the settings menu to see if it eliminates the problem? Doubling up on the updates (both app and OS) can be a challenge.

Apologies for the late response. I disconnected my device from power and re-started. No luck, error still present. I assume, when coding 6.5 a faulty function has been assigned to the “MENU”-key. Lars

I hate to see this but I can confirm I too can’t return to Infuse after entering the “Edit Metadata” screen.

Just as you said, you get dumped out of Infuse and when you launch Infuse again you’re still stuck in the Edit Metadata screen with no hope of returning to the home screen.

This behavior only happens with Infuse 6.5 and tvOS 14 (not a beta)

Infuse 6.5 works normally with the tvOS 13.X

Glad I didn’t update all my ATVs to tvOS 14 :smile:

You have to force quit Infuse and then when you restart it you’re good. At least until you try to edit metadata for any file and it gets locked into that screen.

I need to add, if you choose one of the provided selections below in the search window it will take that and return you to the previous screen and Infuse will work fine. It’s only when you try to back out of the Edit Metadata screen without making a choice that it quits to the ATV home screen every time you hint the Menu button.

No big deal … will you address this to the INFUSE-team? Just in case they are not reading along.
Thanks for making the effort replicating my “strange” finding.

Will do, isn’t it amazing that of the literally tens of thousands of lines of code generated in major updates it only takes a moment after the official release for someone to find that one gremlin line of code. :mag_right:
:rofl:

I wonder if it’s also happening on iOS devices…

I have an original SE and it’s not going to iOS 14 for a long time (if it’s even possible :wink: )

Maybe someone with an iOS device and running OS 14 with 6.5 will chime in.

That’s how it is in life … you prepare and configure something for ages, thinking you got it finally perfect, only for someone coming around the corner saying “… what’s that, this does not look right …”

1 Like

Ios14 and infuse 6.5 on iPad air2 and iPhone XS both work fine.

1 Like

Thanks for letting us know!

Trying to replicate what you’re seeing but if I’m doing it right its fine.
So I opened my movies folder, selected a movie, went to edit and clicked to enter the screen to search or edit, didn’t do anything then pressed menu and it just went back to the movie screen.

1 Like

Two questions, first it looks like you went down the page to the correct movie and it went back to the correct screen, did you press the correct movie or did you hit menu? Maybe not move the cursor down from the search and from there just hit menu?

Second, the op mentioned that it seem to only happen on a TV show so could you give that a shot?

Thanks for hammering at this! :smile:

Okay, the plot thickens…

If you are in LIST VIEW in Infuse settings and stop on an item that you want to Edit metadata you long press on that item and it brings up options one of which is Edit Metadata. Selecting this and then trying to get back to the previous screen without selecting one of the search choices will cause Infuse to quit back to home.

If you are in POSTER VIEW and you want to Edit Metadata you have two options.

First is to click on the poster, then scroll over to the “Edit” icon and then click that. You then go to the search screen and if you don’t choose a selection in the search you can just hit Menu and you go back to the previous screen. THIS WORKS

The other option in POSTER VIEW is to long press on a poster to bring up the options to mark as watched, Edit Metadata, etc. If you select EDIT METADATA there you then go to the search screen and if you don’t choose a selection in the search and just hit Menu button to go back to the previous screen you exit Infuse to the ATV home screen.

To add, thanks to @mrbojangles ! The video gave me a clue to look at how it worked when you use the poster view. I’ve used the List View option since I started with Infuse and forgot that in Poster View you have two ways to get to the edit metadata option.

I’m guessing that @Lars_no_14 also uses the List View option and that’s why it was so obvious.

hi
I confirm all that as correct and replicated with my ATV for movies,tv shows and music videos.

Half the battle in software is being able to reproduce the problem . Thanks for verifying. :+1:

1 Like