Can't restore ATV2

Searched everywhere and can’t seem to find the answer anywhere. And tried a couple different methods that I googled outside of the normal restore (Tinyumbrella, iREB, Seasonpass, Shift + restore, Menu + down then Menu + Play). These methods I get different errors.

My ATV2 worked at one point (jailbroken about 1.5 years ago; can’t remember what version it was), but now it does not display anything on my TV (my other ATV 2 works perfectly fine with all the same cables).

I tried restoring it via iTunes to factory settings (without any jailbreak). I click the restore button and after some stuff, it gets to “Waiting for Apple TV…”. Waited a couple of hours and nothing changed. The ATV2 just has a slow blinking light.

When not trying to restore, sometimes it has a faster rapidly blinking light (not as fast as when i press the menu and play button though).

Hope someone could help (i’m def a noob at this). I’m afraid it’s just broken. I tried going to the Apple store (twice), but they just told me to buy a new one for $59.

Same question here:

try putting the apple tv into DFU PWNER mode using IFAITH then do the itunes restore. Most of the time restoring the apple tv to the latest firmware using the latest itunes works so download the latest itunes. Don’t worry about the jailbreak because at the moment you can still easily downgrade your apple tv back to 5.0.2 to do the jailbreak afterwards. I recommend just getting the apple tv to work first.

Updated iTunes to the latest version. Ran iFaith to v1.4.1. Followed the instructions (tried restoring itunes without pressing the Shift + Restore , and tried to restore to v5.1) but still “Waiting for Apple TV…”.

Also, when it is “Waiting for Apple TV…” the atv2 light stops blinking.

I was going to suggest a few other things but I read your other post and looks like you’ve tried some of that. unfortunately I’m starting to think it’s bricked. I had a similar thing happened to an iphone. the phone won’t re-enabled after the itunes sends the firmware and no matter what I tried I couldn’t it to do the update. Maybe someone else has another suggestion. Have you tried doing it from different PCs?

yup. tried it on 2 other computers. i’ll give it another couple of days in hopes someone has the answer. thanks though!