Can't play VIDEO_TS files on USB drive

Hello, I recently bought aTV Flash because I wanted to play some VIDEO_TS files with my Apple TV from a USB external drive.

To do this I restored the Apple TV to the original factory settings, downloaded aTV Flash 3.5.1, and upgraded the Apple TV to Software version 2.3.1 before patching. I then ran the smart installer within the nitoTV menu.

After all this I can see the external USB hard drive and all my files with the Sapphire menu, and also with Files->Places, but with nitoTV->Files all I get is a message saying that “The folder is empty or has no files with supported suffixes”. (If this is the expected behavior then please tell me what further steps I have to take).

I double checked that I’m using nitoTV version 0.7.1 (take two) with aTV Flash version 3.5.1 under Apple TV version 2.3.1, and that the smart installer has been run.

Is there some step I’m missing here? The USB drive works well with my Mac, and my VIDEO_TS files are OK (& they will play if I send them to the Apple TV’s drive through FTP). I checked other threads in the aTV Flash forums and apparently this works well for other users, but I’ve followed the installation steps to the letter as far as I can tell, but have not been able to play my movies from the USB drive so far. Please let me know if I’m doing something wrong.

Thanks in advance.

Is your hard drive connected as the Apple TV starts up, or are you plugging it in after?

Some drives tend to work better if connected prior to powering on the Apple TV.

Thank you for the quick response. I’ve always checked that the drive was on & available before rebooting the Apple TV, and to be certain I turned everything off, unplugged the Apple TV, turned the drive back on and waited a few minutes to make sure it was available before powering up the Apple TV, but the results are the same. I’ve also tried it the other way around (turning on the drive after the Apple TV was ready).

The drive is a Seagate 750 GB IDE/ATA (PATA) formatted as “Mac OS Extended (Journaled)” inside a NewerTech miniStack V2 FireWire/USB2 enclosure. The only visible file when I mount it on the Mac is a folder named “Movies” that contains several other folders; each one of these contains a VIDEO_TS file, and they are all named after the movie within.

If there might be some incompatibility with this drive, could you please suggest another brand that is known to work with nitoTV? I was thinking of getting a multiterabyte DROBO for this, but don’t know if there are any compatibility considerations one needs to take into account before purchasing a USB drive to be used with the Apple TV & aTV Flash.

In any case, the incompatibility would appear to be with nitoTV only, because the drive is visible to other aTV Flash tools.

Have other users gotten this same setup to work? And if so, what drive brand, model, type of formatting & directory structure are they using? Is there anything else I should try?

Thanks again for any help.

Hi.
I can’t be of any help yet but you might be interested in the following. I purchased, installed, and have used the patch to play lots of mp4 movie files that I transferred to a 1TB external USB Western Digital drive. The movies were compressed from decrypted Video_TS folders using Handbrake and or Visual Hub and they play beautifully. After such quick success in that effort, I then transferred a number of whole ripped movie DVDs (i.e., the VIDEO_TS folders) to another folder created on the WD USB drive. Like you, I had the same unsuccessful results. Am unable to play the "DVD"s. I have written to ATVFlash support and explained my problem. If I get an answer that works, I will let you know.

It’s a shame that no one has created a Manual for the ATV patch because there are so many features that I am curious about or would like to try. I have been reading thru the forums and doing a lot of googling but info is hard to find and organize.

I would just like a set of straight-forward instructions explaining how to transfer riipped movies from my Mac to my esternal WDUSB drive what folder to transfer them into (or to create), and then the steps to go thru to get the movies to play (with Menus, Special Features, etc. --just like a real DVD),

If you or anyone else reading this thread stumbles upon this information please post or email me (admin edit). If I learn anything I too will post on this forum.

Thanks, Phillip

We’ve got a video guide for playing DVDs here:
http://wiki.atvflash.com/index.php?title=Play_DVD_Files

You can transfer the DVD files to the ‘Movies’ folder on the AppleTV to store them locally. Alternatively a link to the external drive will be listed inside the ‘Movies’ folder. This will allow you to transfer them directly to the external drive via FTP.

Hi Again.
Unfortunately, the instructional video that you refer to does not help because “Don” does not describe how to FTP these DVD files (Video_TS folders) to the EXTERNAL USB hard drive. His video, while excellent in most other respects and very well done) only describes FTPing the files to the AppleTV’s own internal drive.

Moreover, despite installing the aTVflash plugin more than 2 times and connecting to the ATV using Cyberduck, my “MOVIES” folder is empty and does not have a link to the external USB drive, as you indicated.

Can you tell us how to create such a link inside the MOVIES folder?

I have several DVDs on the external hard drive, having transferred them directly while the hard drive was connected to my Mac. Each one properly follows the nomenclature rules (i.e., Video_TS folder inside folder with movie title, etc.). While the movies show up in the “Media” selection and also show up in the “Places” section, when I try to use “Files” within nitoTV, I am told that the folder is either empty or does not contain any playable files. The specific error message is identical to the one shown in the previous forum post seen above.

Can anyone suggest a way out of this dilemma?

Thank you so much for any input.

Hi Phillip, I hope you managed by now to get your system working with less hassle than me. The only thing I wanted to do with mine was to be able to play my DVD collection using VIDEO_TS files backed up in a hard drive while the originals were stored safely away (and maybe do some light web-browsing). After some tinkering I managed to get things to work, but not exactly as I would have liked.

What I ended up doing was purchasing a couple of fully loaded DROBO enclosures, where I copied and categorized all my VIDEO_TS folders and hooked them up via firewire to a nearby Mac Mini in the same local Ethernet network, publishing both volumes with SMB and AFP. Because I read somewhere in the forums that AFP streams the data more efficiently I decided to google up and download a suitable “recovery.dmg” file to enable AFP functionality since my Apple TV’s software is not version 1. This step was particularly important fo me, because it made it much easier to transfer DVD files and cover art to the ATV right from the Finder of any Mac in the network. (I also procured a “CoreAudioKit.framework.zip” file to get Adobe Flash to work with Couch Surfer).

After that I performed the steps listed below, and I can now watch my DVDs streaming through the local network from the MacMini. Not the most elegant solution, for it required an additional computer to serve the files, but it all seems to work reasonably well now; although after watching a whole DVD movie I have to return to the Apple TV’s menu before it reaches the end, or else the screen will go black and the system will become unresponsive (At this point I usually just reboot it using the original Apple TV remote, which is a bit annoying, for I have to keep it handy for such events, even when I use my remote of choice for everything else). Also, I’ve noticed that nitoTV crashes randomly while using Apple’s iPhone Remote app (as well as Couch Surfer). Becasuse of this I now use the iPhone Remote only to input text, not to navigate menus.

Anyway, I’ll list here the exact steps I followed in the order I performed them to get this to work in hopes that they might be of some use to you. There’s surely a more efficient way to achieve the same -or better results, but I stopped the trial and error as soon as my setup did what I needed:

  • Restore ATV settings to original “Factory Restore” and immediately after this update the ATV software (to version 2.4 in this case).

  • Put ATV in Settings -> standby and install aTV Flash (disconnect ATV, plug in the patchstick, reconnect it, wait for screenful of text with smiley face at the end, disconnect it, remove patchstick, reconnect it, wait for the process to complete and show ATV’s main menu).

  • Use an FTP application to connect to the ATV as user: “frontrow”, password: “frontrow” (I used Fetch for this, and only once. After enabling AFP I found it easier to just drag and drop stuff to the ATV from the Finder of my Mac).

  • FTP transfer the “recovery.dmg” and “CoreAudioKit.framework.zip” to the “Documents” folder of the ATV.

  • Run “nitoTV -> Settings -> Install Software -> Smart Installer”.

  • Under “Maintenance -> Install Extras”; install “Flip4Mac”, “QuickTime Web Plugins” and “Adobe Flash”.

  • Under “Maintenance -> Manage Plugins”; Run “nitoTV” and “CouchSurfer” updates.

  • Set the Apple TV language (If necessary), “Learn” remote of choice and (if needed) pair iPhone running Apple’s Remote iPhone app.

  • Under “Internet -> Settings”; enable Web Plugins.

  • Under “nitoTV -> Settings -> Install Software”; Install Perian, Install mplayer Codecs

  • Under “nitoTV -> Settings -> General”; set “File Playback Mode” to mplayer, set the Time Zone (and disable “Enable File Deletion” to prevent accidental changes).

  • Under “nitoTV -> Settings -> MPlayer”; set Cache Time to 5 Minutes, and in MPlayer Arguments add the 2 following lines: “-cache” and “102400” (at this point my ATV displays the Apple logo briefly before returning to the menu).

  • Under “nitoTV -> Settings -> Categories”; turn off every setting to keep the menu cleaner and free of unwanted options.

  • Under “nitoTV -> Network -> Add Manual Share Point”; create the auto-mounted AFP share points to access the DVD files available in the network.

I think there might be something wrong with my ATV’s USB port or something, so I’ve stopped trying to play movies from a hard drive attached directly to the unit through USB. The upside to all this is that you could now connect additional ATVs to other TVs around the house and have them all access the same “movie server”. You’d only have to copy the DVD cover art to the “images” folder of each additional ATV, but since the AFP networking works great this task should be trivial.

I’ll try giving the USB issue another go this weekend and report back to you in case I find out anything useful.

Hi joseme.
Thank you for your extensive post about getting the aTVFlash to work with DVDs, etc. Your system seems quite elaborate. I will give your procedure a try and report back on any success that I have. Thank you for taking the time to write such an informative post. I will be following this thread to see what might be forthcoming.
Phillip

Hi Phillip,

I just received a 2 TB Western Digital SATA drive which I put inside a Mercury Elite-AL Pro Oxford 934 FireWire & USB 2.0/1.1 Enclosure Kit. I formatted it on the iMac as OS Plus (journaled) and copied a bunch of DVD files to it.

I hooked this up via USB to my ATV, and sure enough the “The folder is empty or has no files with supported suffixes” message came up as expected. I fiddled some more with the drive and the ATV, but I couldnt get the message to go away. Finally (and I don’t know for sure if this did the trick, but it’s worth a try anyway), I re-ran the Smart Installer a couple of times, rebooted the ATV and the name of the drive suddenly popped up the next time I went to the “nitoTV - > files” menu.

I can now play my DVDs right from the USB drive, just as easily as they play from the networked share points.

I hope you manage to get yours working as well. Give that a try and let me know if it doesn’t work to see if we can figure something else out.

Hi josema.

Thanks for your recent post and suggestions. I tried re-running the Smart Installer several times … no luck, still couldn’t recognize My attached Western Digital 1 Tb drive. I ran the patch-stick again and again ran the Smart Installer … again no luck. Kept telling me that Smart Installer had either given me a partial install or hd failed.

Using Cyberduck, I tried inserting a folder into my movies folder and putting some files in it. They showed up under nitoTV but I couldn’t access the files or play them.

Then, I tried something that did work! I ran the update to the latest version of nitoTV v(0.79) and then ran the Perian installer (that inactivates Apples H.264 player) and poof! My external hard drive showed up in nitoTV>Files along with the DVDs (and their VIdeo_TS folders) I had placed on the WDHD … and they played!

I don’t know why this did the trick because on my upstairs Apple TV, I have not upgraded to nitoTV v.79 (still running v.78 up there) and had not run the Perian installer. Yet, upstairs playing DVDs has not been a problem.

So, much of this is still a mystery, but as long as it’s working–great!

Thank you so much for keeping my problem in mind and for posting. From reading this and other threads on this atvFlash forum, others are also having this problem.

I just hope it’s still working tomorrow when I re-start the system again.

So, now I’ll be working on another problem I’m having. Namely, figuring out how to move the cursor when I try the Internet function of the plug-in. My remote arrows don’t move it, although they are supposed to. Maybe I’ll get a USB hub and connect a mouse, along with the WDHD that’s already connected thru the AppleTV’s USB port.

Thanks again for your posts. It’s nice to know that I’m not alone out there and that people are willing to take the time to help.

REGARDS, PHILLIP

Whoops!
Although I can now play DVDs, I can no longer play many of my compressed movies. All of the movies compressed with Handbrake to mpeg4 video/AAC audio play fine, but all of the videos compressed with Visual Hub to H.264 video/AAC audio only play the audio track. The video does not play.

Apparently, that happened when I installed Perian (which warned about inactivating Apple’s H.264 codec. (I thought Perian would handle the H.264’s.)

What do I do now?
I want to be able to play all my compressed movies (both mpeg4 encoded and H.264 encoded, even if I have to give up the ability to play DVDs( Video_TS).
Is there any way to uninstall Perian and somehow reactivate Apple’s H.264 codec?
Thanks (anyone).
Phillip

I found a solution to my problem and am posting it here in case it can be helpful to others with the same problem. Credit for finding this solution should be given to “madcran” for his/her posts elsewhere in the forum. See: http://forum.atvflash.com/viewtopic.php?f=18&t=1108 - wrap

In an effort to get DVDs to play on my ATV, I updated nitoTV from 0.78 to 0.79 and I also installed Perian (both of these were menu choices within aTVFlash). I installed Perian (using the Software Install menu) despite the on-screen warning that doing this would disable Apple’s H.264. Sure enough, DVDs now played but I could only play my mp4 movies not my H.264 encoded movies.

Apparently, this was the result of the disabling of the H.264 codec. Using Cyberduck, connected to the Apple TV via SFTP (not FTP, because you can’t get to the Root level); Go to the root of the Apple TV, then to System > Library > QuickTime. Although several codecs are listed, the QuickTime H264.component folder is not there. Instead, it’s found in a “Disabled” folder. The object is to now re-enable H.264.

Copied the QuickTimeH.264 component folder from the ATV to the desktop of the Mac (you can’t just move things around within the ATV’s System folder using Cyberduck). Once a copy is on the desktop, Cyberduck can be used to transfer the QuickTime H264.component folder back to its appropriate place on the ATV.

Tried deleting the component from the “Disabled” folder and also tried deleting the “Disabled” folder itself, but they always reappeared. Apparently, the fact that these folders remain within the ATV’s System is not a problem. I did try to upload (transfer) the component folder back under QuickTime (i.e., System > Library > QuickTime) and it did seem to install despite giving me error messages about not being able to complete the transfer (“You do not have sufficient permission to perform the operation”). However, I don’t think that doing this transfer helped re-enable the H.264 codec. In any case, I ignored the error messages.

I then transferred another copy of the component folder from the Mac desktop to Users > frontrow > Library > QuickTime. This was the crucial step in re-enabling the QuickTime H.264 component. After restarting the ATV, DVDs played and so did my H.264 compressed movies.

Great news Phillip, glad that you managed to get things to work. I hope your setup is in good enough shape to satisfy your needs. In my case, I noticed that enabling Perian would mess up my ability to watch movie trailers or YouTube clips, so I decided not to enable it on my ATV from now on, and just use Apple’s H.264 to avoid this problem (I can still watch my VIDEO_TS folders regardless). I was about to warn you about this, but I then read your last 2 posts where you fixed everything yourself.

I haven’t experienced the cursor issue you mentioned in Couch Surfer. Is it something that started happening recently, or has your browser never responded to the remote?

I’ll get back to you if I come up with something that might help.

Hi josema.
Thanks for the post. I’ve not been able to move the cursor using the Apple remote since day 1. I can scroll the web page up and down using the up and down arrows of the remote, but the cursor remains in place on the screen. However, I have a USB hub and will try it with one of the mice I have for my Macs. Will report back with results.
Phillip

I have had success in getting a USB powered 2.5 external hard disk working with aTV Flash this morning (3.6.3).

I am able to watch VIDEO_TS files only by navigating nitoTV > Files > External HD > Movie (Play Title)
Using the Files > Places > External HD > Movie (VIDEO_TS) leaves me at a blank VIDEO_TS screen for all movies.

My observation is that when I navigate through the nitoTV path, the application is correctly detecting (Play Title) of the VOB files.

I should also note that not all of my videos are playing. I think I had used MactheRipper to do most of them, but I’m going to re-rip and see if that makes a difference for those that are not playing.

Peter

I have just discovered that my Western Digital 1.5tb Green HD when formatted with FAT would only play DVDs/Video TS rarely, however when formatted to MAC OS Extended (Journaled) with owners enabled, as per my system disks, now seems to work fine.

Hi, I’ve got a small suggestion for the aTV Flash team regading their Wiki documentation and the use of external USB hard drives as primary storage.

I’ve noticed that some hard drive enclosures that come equipped with both USB2 and FireWire ports may sometimes require formatting while being connected through FireWire (instead of USB).

I’ve tried formatting these drives as Journaled while mounted through USB with Apple OS X’s disk utility tool, but the process always ends with an error, nevertheless these same drives will format flawlessly while connected through FireWire.

After formatting them with an iMac, I could then connect them through USB to the ATV and configure them as iTunes storage using the Terminal commands provided in previous aTV Flash online documents without issues.

Now that version 3.6.4 of aTV Flash has a menu option for setting iTunes Storage to internal or USB, all I get is an error message whenever I try to set my hard drive as primary storage, and I suspect this is because of the same issue that prevents me from formatting it through USB.

Because of this, I think it would be useful to include in the Wiki the command-line procedure that was previously available using the Terminal, or at least to post it elsewhere for people that might share this problem. I’d be grateful if someone with a cached version of these documents could post the Terminal commands here, as I couldn’t find them myself.

Thanks in advance

The original command line guide can be viewed here:
http://wiki.atvflash.com/index.php?title=USB_Primary_Storage&oldid=4031

Thanks! worked great.