Can't play .mpg or .avi files on NFS share

AppleTV take 2, used aTV 3.2.1.

MPG Files
I mounted an NFS directory (created in DVD->Network) with MPEG-2 files (from mythtv, recorded on Hauppauge PVR-250). When I browse to them through DVD -> Files, when I get to a folder containing mpg files I get the message: “Empty Folder! The folder is empty or has no files with supported suffixes”.

I have installed mplayer codecs, and under DVD -> settings File Playback Mode is set to mplayer. I installed Perian, and setting the Playback Mode to QuickTime produces the same error.

AVI files
On a different NFS share tried to play an AVI file (which showed up in the directory) by going to DVD -> Files. Pressing play did nothing - no error message.

Note: when files copied over locally, could play the AVI file (Xvid) through Files -> Movies and DVD -> Files. For MPG file, when copied over locally, couldn’t play either through Files -> Movies or through DVD -> Files. In fact, trying to play the local MPG through DVD -> Files rebooted the AppleTV!

This is starting to get a wee bit frustrating. I know that mplayer can play these mpeg/avi files as I have done so numerous times with mplayer on Windows, OSX and Linux.

Many thanks to anyone who can help out.

Mea culpa - at least some of the issues have been tracked down to permission issues on the NFS mount, so problem there was between monitor and chair; however am still having issues with file support, and varying levels of performance.