Can't mount my ReadyNAS with Nito TV

Hi,

I’ve tried many of the solutions on this forum and the wiki to try and get my readyNAS to mount with SMB. Including deleting the combo updater and downloading another and uploading using Cyberduck.

I’ve had various error messages along the way but this is the one I am getting now…

mount_smbfs:mount error:/mnt/Scratch/
Volumes/media: syserr= Resource busy

Network settings are as follow

Mount Name: OurDisk
Mount Type: smb
Mount Address: OurDisk.local
Requires Authentication: No
User Login
Password
Volume Path Media
Auto Mount On
Use Custom Path Off

The ReadyNAS is called OurDisk and ‘media’ is a share on the ReadyNAS where I store my media obviously! When I tried to use just OurDisk as the Volume Path I got this error.

mount_smbfs:tree connect phase failed
syserr= No such file or directory
mount_smbfs:tree connect phase failed
syserr= No such file or directory

I’ve resisted using the custom path option as the wiki advises against it.
It’s nearly 1.30am I’ve been at this all night and I just want to play with my new Apple TV!
Can someone please put me out of my misery and grant me the wish of a mounted drive when I wake up in the morning…where’s that Guardianmax guy? Prove to me that this isn’t beta and it will change my life!

Should say that NITO sees the drive as AFP and I am attempting a manual share but changing it to SMB as AFP is not really supported unless you have Apple TV version 1.0 apparently. So I’m not really changing many of the settings because they are already populated. The drive only needs guest access so user name or password is not required.

Thanks in advance

Ok so I’ve been reading even more threads and someone connecting to their PC had ‘resource busy’ error. Obviously I’m trying to mount to a Ready NAS so slightly different. The advice was to restart and try again, I’ve done that with the ReadyNAS twice and no luck. I even stopped AFP broadcasting over Bonjour in case there was a conflict between AFP and SMB.
I also read that you need to use the admin username and password when mounting with Nito so I have added that as well but still no luck. I feel like all the settings are nearly correct there is just one vital part missing.

Current Settings are:
Mount Name: OurDisk
Mount Type: smb
Mount Address: OurDisk.local (also tried with ReadyNAS IP address)
Requires Authentication: Yes
User Login:xxxxx
Password: xxxxxxx
Volume Path: media
Auto Mount: On
Use Custom Path: Off

and this is the error

mount_smbfs:mount error:/mnt/Scratch/
Volumes/media: syserr= Resource busy

Username and password are definitely correct as I can mount drives on my Mac with them no problem

Someone please help, my wife is starting to question the wisdom of me spending £230 on an Apple TV and more importantly $49.99 on ATV Flash because without this feature working both are fairly useless to me unless I want to start renting from itunes store.

I’ve already emailed support I just hope someone gets back to me soon

Thanks

Final update before I go to bed after another unsuccessful night of trying to mount my ReadyNAS in Nito TV

Got an email from support who advised me to restart ReadyNAS and Apple TV, but I’d already read about that solution on another post and had tried it several times. I emailed support straight back asking for other ideas but no reply.

Just out of interest I installed ATV files and with that I was able to see the folders on my ReadyNAS, couldn’t do much else but I know that it must be a NITO problem rather than my network per se.

I’m talking to myself here but I’m just hoping someone going to come along and give me a solution, I guess this is the sort of forum you only browse if you have a problem rather than a solution.

Support please HELP!!

I have same problem but different drive and, like you, seem to have tried everything.

I also posted problem on the forum looking for a solution but no success and no suggestions so far.

I have the same issue. I just used the networked drive from my macbook pro yesterday and with no issues with XBMC. Now, the next day I have a resource busy error that no one seems to know how to fix…it has been 4 hours of searching and there are no real answers.

How frustrating…it worked fine, now doesnt and the only thing that changed was my computer restarted.

I’m having the exact same issue with my QNAP 459 Pro.

Would be nice if someone from firecore dare at least to reply to us, een to say that they don’t know how to solve the issue. But at last we can stop asking.

But of course, if someone has an idea, he’s more than welcome !

Jean-Frederic

i faced this issue as well.

How I got there was:

 

1. Mounted my smb share (synology NAS)

--> This worked fine, until i tried to add custom mounts

--> Then the error popped up all the time.

 

I think its something to do with trying to mount a share that is already mounted?

 

Anyway, i removed the mount, rebooted, added the mount again, and things worked again?

 

perhaps u could try that...