Can't Mount My Mac Mini on NitoTV

This seems to be a problem for many....

 

My problem is like most of you, but with a twist.  I do not have a password set on my Mac.  For example, when I have to install something, and my login and password comes up, all I have to do is hit "Ok" and it will install because I don't have a password set for my computer.  Now...when I try to create a manual share point on my NitoTV Network...

 

1. Requires Authentication: Yes or No?

If No, then do I not have to put anything in my login and password section of the network set up?

If YES, then I take it I put in my login in the Login section, but what do I put in my Password section of the Network set up?

 

This is what I have done so far...

The directions I followed is as below: (BTW, I'm on Mac OS 10.5.8)

1. Went into System Preference and checked File Sharing and added the folder
with my movies in it.

2. Checked off Share files and folders using SMB in Options button and added
myself.

3. Found my Mac in Network (Nito TV) and created a Manual Share Point.

4. Mount Type - smb.

5. Mount address - left alone.

6. Require Authentication - Yes.

7. User Login - my long info here.

8. Password - I don't have a password for my Mac.

9. Volume Path - Apple TV Movies

10. Auto Mount - No.

11. Custom Path - None/No

12. Save Mount Point.

 

When I try to mount....FAIL!!!  Can someone help?

Do what I did: create a password for your account.  Now all of my Macs mount thru NitoTV...

 

I've discovered that the 'Volume Path' is NOT actually the name of the volume that you've got the shared folder on (ie. NOT 'MacintoshHD'), rather it the NAME of the shared folder that you created in the File Sharing setup (that has your movies in it).  It is only a Volume name if you're trying to mount an external Volume (ie USB drive) - which also needs to be added as a shared folder in the File Sharing Prefs.