Cant load subtitles atv4

Hi all,

i bought a license for infuse 4 pro and i am using it for a while now. Also
on my apple tv 4. Till now i was able to import subtitles to my movies in my
Nas but since today it doesn’t work anymore.

When i go to subtitles and click on ‘get more’ i get the following message:
‘An error occurred. Unable to download subtitles. Please check your internet
connection and try again.’

Can you help me with this. Tried to figure it out al evening but i can’t find
the solution.

Greetings Martin

Hi. Same problem. My Apple TV 4 is on the latest version. I think 2-3 days back was everything ok and it worked.


Same here… :frowning: Very annoying.

same in here… I paid for pro but when I try to choose subtitles I got an error, telling me to check my internet connection… Changing DNS settings of atv4 might be a solution?

This is likely related to the availability of the OpenSubtitles service.

They have been working to upgrade their infrastructure this week and last, so things should be working much better after this week.

Hi, I’m also having this problem since about a month ago… reset my atv4 and reinstalled infuse (even upgraded to v5!!!), same problem…
Checked the opensubtitkew availability and it’s green. Help pls!!

Same issue here (Infuse 4 Pro). It doesn’t seem to be related to the OpenSubtitles service, since it’s working with Kodi for instance.

Same problem here with Infuse 5.

If it helps for the troubleshooting… In the past, when clicking on the subtitle menu, I got a “recommended” list of subtitles to use, where I’d just select one. Now, that left side menu with the recommendations is empty, and I have to search for it. When I click on search, it does present a big number of available subtitle options, but when selecting one, I get the error message with Check your internet connection.
I’ve tried everything both on the ATV settings, as well as Infuse (4 and 5).

It’s working now… as suggested above, it was probably a OpenSubtitles server issue.

I can confirm it… as of today, the subtitles are loading again!!

OpenSubtiles does tend to become unavailable at times, and in the future you can check the current service status here.