Can't load external subtitles when using drag/drop (or Open With)

I am accessing the video from smb.

I followed the document at https://support.firecore.com/hc/en-us/articles/215090967-Using-Subtitles , rename the .mkv and .ass to the same filename except the suffix.

But Infuse still cannot load the ass file.

However, if I open the same video file on iOS, Infuse can correctly load the ass file.

1 Like

I find that it is because I open the video directly from Finder. If I add samba in infuse manually, Infuse can load subtitles.

But if the infuse can load subtitles automatically when using finder? IINA and movist pro both can do that.

It pretty mad that Infuse on Mac can’t even load external sub for local video.

Tic Tac, let’s see if they fix it before I cancel my trial period. I’m not gonna pay for something that has such a basic flaw. I was really confused why It wasn’t working, and had pretty high hopes for this software.

I’m going to guess that you have a misspelling in one of the file names.

I just loaded a test file and test subs on my Mac and it worked first time without issues. Here’s the file name and structure.
Subtitle Test file name and structure

And here’s what I get in the playback screen for “Sample 720.mkv” screen when selecting subs.

If you could post a screen cap of your video and sub file structure and names like the pic I posted above we can try to figure out what’s going on. :wink:

Video Screenshoot

And the two files, in my external disk
image

The ass file

.ass is downloaded from https://bbs.acgrip.com/thread-7280-1-1.html

The .ass file doesn’t appear to have the fonts included. I don’t know a lot about subs but from what I read your file needs to include the fonts for the .ass format. I checked my demo file and it has the fonts after the [V4+ Styles] and before the [events].

Maybe download another .ass sample and make sure it has the fonts in it and see if it shows up in the playback options then.

Also, have you looked for a different type of subtitle other than the .ass?

I create a srt sub with only the following lines:

1
00:00:00,000 --> 00:00:01,000
1111111

Infuse still cannot load this file.

And, as I said, if I manually add the path in infuse with “Add Files”, infuse will load the subtitles.

I’ll add that drag and drop a srt sub to infuse playback screen also not supported.

You have to click the gear icon and do the import step, very iOS-ish. But it’s not how people use a MAC app.

Obviously MAC infuse is not catered to local playback at the moment. I’m pretty shocked TBH.

1 Like

Unfortunately, there are technical limitations here as macOS grants access to a particular file when using drag & drop (or Open With), and this does not extend to other files which may be located nearby.

One thing you can do to workaround this is to place videos and subs in the Movies/Infuse folder, and access these videos through the Files tab in Infuse. There, Infuse should be able to access both videos and subtitles.

2 Likes