Can't launch FireFox (or any app)

When I choose DVD -> Applications -> Firefox (or any other app that I’ve uploaded to the “frontrow” Application’s folder), the Apple TV menu disappears, an Apple appears, and it sits there forever.

I’ve even done a fresh install from a factory reset. Still won’t work.Here’s what I’ve done:

  • restore from factory to 2.0 (that’s what my Apple TV came with)
  • update to 2.2
  • install ATV 3.3.5 (no errors or problems). Rebooted twice.
  • FTPed to Documents:
    MacOSXUpdCombo10.4.9Intel.dmg
    MacOSXUpdCombo10.4.10Intel.dmg
    CoreAudioKit.framework (from a fresh install of 10.4 updated to 10.4.11)
  • ran Maintenance -> Install Flash
  • ran Maintenance -> Install QuickTime
  • ran DVD -> Settings -> Install Software -> Install Turbo’s Kextloader
  • ran DVD -> Settings -> Install Software -> Smart Installer
  • FTPed to Applications:
    Firefox.app fresh from a .dmg for Firefox 3.0.4
  • rebooted Apple TV
  • chose DVD -> Applications -> Firefox

I’ve waited 10+ minutes. But nothing happens at all. I’ve tried other applications, and they all function exactly the same way.

Any ideas?

Ok. Think I figured it out. Looks like when FireFox.app was copied over, it lost all its permissions.

From a terminal (ssh -1 frontrow@AppleTV.local), do this:

chmod -R 777 ~/Applications

That fixed it.

Hello.

This is what I have done to install Firefox with no succeed.

  1. Upgrade Apple TV’s firmware from 2.0 to 2.3.
  2. Install ATV Flash 3.5 on Apple TV, installation succeeded.
  3. Copy MacOSXUpdCombo10.4.9Intel.dmg and MacOSXUpdCombo10.4.10Intel.dmg to the documents folder into the Apple TV.
  4. Run nitoTV/Settings/Install Software/Smart Installer, Installation succeeded.
  5. Copy CoreAudioKit.framework to the documents folder into the Apple TV.
  6. In Maintenance/Install Flash, Installation succeeded. Maintenance/Install Quictime, Installation succeeded.
  7. Copy the Firefox.app from a Firefox 3.0.6.dmg.

This is what I get when I try to open Firefox:

Pressing Firefox in nitotv/applications apparently it starts just fine, but after 1 or 2 seconds the screen goes black. Being the screen still in black, I’ve noticed that if I hit the play button on the remote the black screen disappear and firefox explorer appears but just for 5 or maybe 10 seconds then the Apple TV reboots. After the reboot, if I open another application like Boxee or XBMC, before any of them starts, the firefox explorer shows up for an instant and then appears the application that I’ve opened, that means that firefox is still running at the background.

  1. Does somebody knows what’s happening with Firefox? (In this case)
  2. What can I do to solve this issue?

I will appreciate any kind of useful help.

Thanks in advance.

Robert.