Can't jailbreak my AT2

Hey

I desperatly need some help. After I have used Seasonpass to jailbreak my Apple TV2 and connect the ATV2 to my TV my ATV2 just starts blinking and the screen only shows a iTunes logo.

I have used this guid: http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass

What I did was:

  1. Disconect my ATV2
  2. Start Seasonpass and click on create IPSW
  3. I wait and follow the guid on the screen
  4. After iTunes stops I disconnect the ATV2 from my Mac and connect it to my TV.

Now i’m only seeing the big fat iTunes logo.

What do I do wrong?

This is expected behavior as it sounds as if the ATV2 is waiting for a tethered boot to be carries out as described at http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass

The current jailbreak is ‘tethered’ which means that every time you lose power or do a hard reset on the ATV2 then you have to reconnect to the PC/Mac that did the jailbreak to complete the boot using the Tethered Boot option in SeasonPass.   In practise this means that the ATV2 has to be located where it is going to be used and the PC/Mac bought to it to do the tethered boot stage.   Once you have done the tethered boot you remove the USB and plug in the  HDMI - you must NOT disconnect the power cable during this process.

Great!

I was such a foul. I forgot to plug-in the powercabel when I used tethered.

It looks like all is fine now. Thanks for the help.

This latest SeasonPass has confused a few of us.

After trying to setup a non tethered installation (i kept on getting the iTunes+USB icon), i finally thought I would try a tethered setup. This just worked. very frustrating.

 

I have also discovered that the latest version of FireCore did not work on both of my ATV’s, as it could not find them on my network. I turns out that it was an IPv6 issue. Manually entering the IPv4 addresses did not find the devices.

Although the ATV had an IPv4 address, seen in the settings>about menu, the ATV did not respond to a ping. I tried disabling IPv6 on the the Windows 7 I have used many times before to upgrade my ATV’s. This didn’t change the situation.

I then disabled IPv6 on my router (AVM Fritz!Box 7390 - with native carrier IPv6). The auto discover still didn’t work on FireCore after this, but I was able to put the IP addresses in for both ATV’s. Both updated with no issues at this point.