Can't Jailbreak my appletv

Hi All,


Just purchased aTV Flash for my brand new apple tv black box. Downloaded all the latest software to jailbreak my device to install aTV Flash. Successfully created an IPSW, then connected my apple TV to my macbook to update but the software can’t see my apple tv. I know the usb cable is fine as when i launch iTunes my apple tv is visible.

The version of Seas0nPass is Version 0.7.9 (290 

Any one got any idease please as it would be a shame to request a refund for my aTV Flash software.

Thanks in advance :) 

I am confused!

You say that you have created the Jailbroken .ipsw file that needs to be restored using iTunes. You then say that you cannot see the ATV2, but in the next sentence say that iTunes sees it. You seem to be contradicting yourself!



Ok this is whats happening-

I point the Seas0nPass to the ISPW file AppleTV2,1_4.4.4_9A406a_Restore.ipsw it then processes and asks me to attachedmy appletv via usb for see attached screen shot, once i do this nothing happens.

This DOES work, trust me. I am running 4.4.4 Freedom!( I think we should change the name to liberated rather than jailbreak, but JMHO).

I found that I had to have both the micro USB and power attached when pressing for seven seconds. I also found that it is best to do this with a clean reset of the computer and close all unecessary applications.

I know it can be frustrating, and I’ve been there, but it DOES work.

I am really impressed with the streaming capability of my library of movie downloads.

Very nice.



Let me know how you get on.




Oh yes, I forgot, you may need to use a different micro USB cable. The cables CAN cause issues as well.


I think that one of the issues new users have is the amount of conflicting methods posted for various versions and builds of the ATV2.

I can only comment on what worked for me, and since you are having the same kind of issues I had(unable to get into DFU mode) I think my suggestion and method will suffice.




Nice one Ed, it was the power cable that worked. Plugged in while jailbreaking and all worked. Happy Christmas.




Seems quite a few people are getting this problem with low power USB ports… glad you got sorted!


Great! HAve a great New Year




And you… happy days.  :slight_smile:

I tried everything to jailbreak my Apple TV2 gen with 4.4.4 including plugging in the power and I finally got it past that to where it opens iTunes and restores but then it give me a error message saying can’t restore and that is where I’m stuck. Any ideas?

The exact error is “The Apple TV “Apple TV” could not be restored. An unknown error occurred (2)”

Exactly the same error message appeared for me. I used Seas0npass for Windows Version The restore in iTunes results in: " Apple TV could not be restored. An unknown error occured (1604)"

The problem was solved when I disconnected all USB-hubs and connected my Apple TV 2 to an USB-port directly on the motherboard (backside of the computer) instead of to an USB-hub. Peculiar!