Can't jailbreak AppleTV 2 even though process complete

Hi everyone,

 

I’ve been trying to JB my ATV2 over and over again with no luck. The components I’m using are as follows:

  • Firecore 0.8 - newest

  • AppleTV 2 - with 4.4.4 (3330) firmware

  • Macbook

  • Latest iTunes.

 

The problem is, I went through all the instructions and even though Firecore says the process is complete, the ATV2 is not jailbroken. I know this because I can’t SSH to it nor do I see the FC logo when I book my ATV2. One problem I encounter though is that Firecore says the JB is complete but iTunes has a message saying that “the AppleTV cannot be restored. This device isn’t eligible for the requested build”

Any help would be greatly appreciated! Thanks!

same here… have tried it twice

so basically i jailbreak JUST to have itunes restore it to an UN-jailbroken state, W T F  this is total shite… what am i missing??? someone please help!!!

Install TinyUmbrella and follow the instructions in this post: http://forum.firecore.com/topic/4328  Worked for me when I had the same problem :wink:

thanks but alas nope!  which sucks… it takes me 10 minutes to set this shit up every time… i have tried 3 times and FAIL… it does NOT jailbreak, just restores the damn thing… fuck this shit

It sounds as if the Restore phase is not picking up the Jailbroken .ipsw file! When the Jailbroken .ipsw has been created are you selecting the Automatic method of launching iTunes? If so it might be worth instead selecting the manual method as that allows you to select via using Option-click on the Restore buttion and getting a file dialog the .ipsw to be restored. That way you can make sure it is the correct one (it will have _SP as part if the filename).

Also make sure your Atv has enough power to complete the Jb. Check the other post about inserting your power cable after inserting the USB but before you enter DFU mode.

This was a documented issue with JB’ing ATV’s back in October with Version 4.3 and they fixed it at the time, but now it appears with the 4.4.4 launch Seas0npass is not creating the AppleTV2,1_4.4.4_9A406a_SP_Restore file but rather just AppleTV2,1_4.4.4_9A406a_Restore (notice missing the SP prefix to restore) which is essentially just the standard ATV 4.4.4 software thus the JB process is actually just doing a standard restore…

 

I’ve tried everything that was  documented but it seems that the Seas0npass script is going to need to be updated to actually create the SP file so we may just have to wait till they fix it

 

This was a documented issue with JB’ing ATV’s back in October with Version 4.3 and they fixed it at the time, but now it appears with the 4.4.4 launch Seas0npass is not creating the AppleTV2,1_4.4.4_9A406a_SP_Restore file but rather just AppleTV2,1_4.4.4_9A406a_Restore (notice missing the SP prefix to restore) which is essentially just the standard ATV 4.4.4 software thus the JB process is actually just doing a standard restore…

 

I’ve tried everything that was  documented but it seems that the Seas0npass script is going to need to be updated to actually create the SP file so we may just have to wait till they fix it