Can't Jailbreak Apple TV2

Hey guys I am having trouble getting my ATV2 to jailbreak.

When I jailbreak after I plug the HDMI back in there is no FC logo in the setting so ATVFlash can’t be installed. 

Tried restoring my apple tv mutiple times and unpluging it from my PC and into the tv to ensure everything is working properly before Jailbreaking.

The Jailbreak says it is complete and I unplug the USB and HDMI back in before the front of the ATV2 is flashing.

I’ve also ran ATV Flash just to check if maybe i wasn’t getting the logo but its says atv2 is not jailbroken.

And the power to my ATV is never unpluged once its in DFU mode for season pass.

I have the latest version of season pass or windows, applte tv ios 5, and i tunes

Any suggestions before i go completly crazy?

 

 

SO after much playing around i finally got it. When you’ve finished boot tether the guide says to quickly disconnect usb and plug in hdmi before atv stops flashing. \i tried waiting for it to stop flashing and then switch and and voila first try. anyone else having these problems try that.