Cant install any extras

Hi yesterday i jailbreak and bought atv flashblack, the process went smooth untill I had to install the extras like infuse, rss feeds, etc. Everytime I click on the installation button it shows me an error messages of “installation failed” the log file shows “dkpg was interrupted, you must manually run dpkg - configure a to correct the problem” The only extra I could install was xbmc but none of the rest work. Being my first jailbreak I dont have any backed up versions to go back to, what can I do?

I’ve seen suggestions that re-running the ATV Flash install from your PC/Mac can clear this issue.

Failing that the error message should tell you the dpkg ommand you can run from a ssh session to clear that error.

The ultimate fallback is to start again with a fresh jailbreak.

Thanks the reinstallation actually solved the issue, however here’s a note if someone has the same problem, xbmc is actually causing it, so make sure to install it at the end, because after right you install it the error starts.

Thank you for your answers. I had the same problem and a re-installation of ATV Flash solve it.

Can you inform it in the tutorial because it isn’t so easy to find the right topic in forum.

Thank you for your work.

i had the same issue yesterday when i updated from 4.4.4 to 5.3 and what solved it for me was to ssh to the atv and manually fix it, i did it on a mac as such:

 

*open terminal

  • type ssh root@“the home ip of your atv”

*type the password ( if you didn’t change this it is alpine)

  • type “dkpg --configure -a”

 

hope this helps anyone