Can't get USB drive connected

I’m brand new to ATV Flash. I successfully installed the patchstick tonight and updated Nito as instructed to allow external USB drive connection. However, when I select Files under Nito, I just get a beep and nothing happens. Pretty clear that the ATV isn’t recognizing any attached drives. FYI, I’m using a 1TB Fantom Green Drive:

I’m pretty sure it’s formatted FAT32.

Any advice on how to get this to work? Ultimately I want to have this drive network attached (via Airport Express).



Same here and even more! I have 2 apple TV at home one is 2.4 OS and other just as experiment is 3.0 OS. I got Lacie 1 TB drive formatted as mac os, and it is recognised fine with my older 2.4 OS apple tv, but OS 3 have the same trouble as previous member described. Just a a beep in File (nitoTV) menu and nothing happened.
If I understand correctly I have to run a smart something in NitoTV to be able to access my external hard drive? right? I did that a couple of times and still nothing.

I have a creazy thought - may be you need to put at list one file into NitoTV File directory (not on external drive, but to internal apple tv drive) to be able to access file menu and then external drive? Am I correct?

Be sure the Smart Installer ( has been ran, and the AppleTV restarted afterwards (disconnect and reconnect power).

That’s the first thing I did, as explained in the ATV Flash instructions. What else do you suggest?

Was the AppleTV restarted (disconnect and reconnect power) after running the Smart Installer?

Also you may want to double-check the format of the drive. The AppleTV will only support Mac OS and FAT32 formats.

Yes, I did restart the ATV a few times. I’m pretty sure it’s FAT32 format (my Airport Express can see the drive). I’ll see if network attached works better…

Same thing with me, and I am using a drive that was workng until the aTV flash 4 upgrade. SmartInstaller installed but I just get a ‘beep’ and if I try to install aTVfiles or use pretty much any ‘nito TV’ or ‘Maintenance’ menu item I get an ‘error has occurred’ message and have to restart

I have the latest updates for both ATV Flash and the Apple TV software and cannot get my USB hard drive to be seen by the Apple TV.
Can’t see it in Nito TV or Sapphire…
Have run Smart Installer and restarted numerous times.
Using the same drive I have been using for months before the update.
Any suggestions?

Same here.
E-Mailed aTV. They said to try and connect USB after AppleTV boot up.
Worked for me.

same here, if anyone gets an answer, please post it. After the update, cannot access the files on my external drive (Ran the smart installer as well)

I also have the same issue - tried various on/off plug unplug procedures with no joy. Nito does not see a USB device at all - V frustrating as this was principle reason for purchase of atvflash. Running os 3.1 and a Apple Timecapsule 500GB drive connected via USB - Drive is set up wireless as well but I have removed LAN connection to avoid conflicts - still no joy

Any thoughts - someone must have an answer or is it just broke.

I am having the same problem as well. When I first installed aTV Flash all went well and the external usb drive (WD MyPassport) showed up and worked. When an unrecoverable error occurred and screwed everything up, I had to reset the aTV to factory specs and start over again. After going through the Apple update and installing the aTV Flash for the second time, I am not able to get it to see the external drive. I then re-installed aTV Flash and still no joy. Any help???

Just done the Nito TV updates and still no change - is it something to do with the time-capsule root being a share-point? I’m going to get another USB drive a Lacie or something similar - anybody tried with a variety of drives?

What size and format is the drive? The AppleTV will support drives up to 2TB in size in either Mac OS or FAT32 format.

I had all the same problems everyone has had with getting an external HD to be recognized. It worked before on a previous version, but just like everything, when you upgrade, you always seem to lose functionality and have to jump through hoops to get them working again. Notice how every reply from the forum administrators are the usual “did you run smart install?” Well, duh. If we went through the documents to see we have to run Nito, then yes, I’m sure we loaded what we are supposed.

Anyway, my fix turned out to be rather simplistic-after plugging into my Mac and that didn’t see it either, I knew it was HD related. All I did was power if off, power back on and the Mac saw it. Plugged it back into AppleTV and it to recognized it. I had to go back to Computer and re-find my Mac to sync it with Itunes, but after that, everything worked fine.

I was lucky-if you haven’t powered off your HD in awhile, give it a shot-couldn’t hurt.

It’s a 500gb Timecapsule so that shouldn’t cause any issues - the media is stored in a standard ITUNES setup my movies in the movie folder alongside all of our music - we have about 350gb of media on the drive.

Unfortunately you a Time Capsule cannot be connected via USB to the AppleTV. You can connect via Ethernet, and setup a share point as described here:

Is this only for accessing non-iTunes media? I want to keep my media in iTunes, but have it all stored on my time capsule. I tried to stream the content, but I was experiencing so many problems I decided to get aTVFlash in order to expand the hard drive. Basically, I’m fine with using the iTunes/normal apple tv interface (my media is all converted to .m4v) but I want everything accessible on the TV even when my laptop isn’t around. Will the share point help me to accomplish this?

I’ve gotten myself quite confused reading all the different solutions, I need some help!

You can keep your iTunes media but I would suggest you create a different folder for non iTunes media. This way you can still have the iTunes media play via iTunes; and nitoTV or XBMC can also play both (add both folder as additional source)