can't get past "preparing apple tv for restore" using seas0npass

i am trying to jailbreak an apple tv 2.  seas0npass does its thing and open itunes and start the restore process.  it gets to " preparing apple tv for restore and stays there until eventually i get the 1601 error.  i can restore the apple tv with itune no problem, but not when using seas0npass to jailbreak it.  i am getting frustrated here.  i have jailbroken many apple tvs before and after this one and this one is the only one giving me these problems.  i have also tried doing it with the power plugged in and still no luck.  i did make sure it is an apple tv 2 and it is, so i know it is NOT an atv3.

 

does anyone have any ideas? 

 

also, after seas0npass opens itunes and starts restoring, my computer says something about using a 2.0 usb port for faster speed, but thats all my computer has and i have jailbroken many apple tvs using the same port and do not get that meesage with any other apple tv.

 

thank you in advance.

does anyone have any ideas for the above problem?

Probably sound like a really simple thing, but have you tried a different USB cable?

I have one cable that works for ATV jailbreaking, its a very small, about 6 inch long one that came with a blackberry, anything else doesnt work, also I have to use one specific USB slot.

Its very temperamental.

close itunes when it gets stuck (about 10 secs after it opens will be fine to close). 

then run iREB-r5 (google it if you havent got it). let it do it’s thing. without closing anything -

open itunes keep shift button pressed and click restore - click “appletv2,1_5.0.2_9B830_SP_restore” if you can’t it find look in the seasonpass folder and it will be in there.

should now do it manually for you.

I have tried all this, even tried another cable and computer. Shouldn’t be the cable, I can jailbreak other atv’s with this cable. It seems as if it doesnt stay in DFU mode.

Did you ever find a solution to this?  I seem to be stuck in the same spot.  I have tried two different cables so far.

Nevermind – I figured out what I was doing wrong.  When I held the two buttons waiting for DFU mode I assumed it would go into DFU mode while i still holding the buttons.  When it did not, I released the buttons and then held them down again.  However, the release of the two buttons on the remote sent it into DFU mode and then holding the buttons again and releasing them triggered some other state on the Apple TV 2.

 

The moral of the story for me was this:

  1. Hold the buttons

  2. Count to “7 Mississippi”

  3. Release the buttons

  4. Put down the remote and don’t touch again until the Apple TV is done restoring and connected to your TV

 

This is happening to me as well, I know my cable works, tried with both laptop and desktop, keep on getting “Error -1” in Itunes just when it starts the Restore process (after verifying with Apple). Will wait on a fix, just gotta be patient :) 

 

Look at my comment above – apparently I was being too “touchy” with the remote.  That is to say, after it goes into DFU mode you need to set the thing down and let everything run its course.  My mistake was thinking that I had to hold the remote buttons until it went into DFU mode.  When it did not go into DFU, I would release the buttons and press again.  However, upon release it would suddenly go into DFU mode and my subsequent “press again” (followed by another release) would actually foul things up for the Apple TV 2.

 

I did not realize how touchy it was.  So when I did it again I just gave it the 7-8 second hold, then released and set down the remote.  Sure enough, the Apple TV 2 went into DFU mode a second later and then after 5 failed tries finally installed the jailbreak.

 

You know, I too am in the middle of this :frowning:

I’ve done a few ATV2’s before, but with this one iTunes WILL NOT WRITE the Seas0nPass ipsw. It just refuses… Dozens of attempts, different cables (All cables write the “virgin” Restore5.0.2 ipsw easily, without a hitch). Different SP labeled ipsw’s. I unplug the ATV2 after each attempt, tried “Fix Restore” in different programs, after it craps-out during the SP process I just point iTunes to the ipsw it created (larger and with the SP in it)

If I run iReb (5or6), or Any other DFU-PWNing programs first, iTunes won’t recognize the ATV. If I 2-button the unit I hear the laptop do that USB port “ding-dong” and Bang it shows up in iTunes (that un-does the iReb stuff though - right?) but after “Extracting” and “Preparing” it Errors 16XX EVERY TIME…

Win XP - iTunes 10.7 (or 10.5) - same cable I did every other one with, latest Seas0nPass, also tried iFaith, Redsn0w, tinyumbrella. Do I have to goto SnowBreeze? :smiley:

Use the power cable when putting it into DFU mode. Once it is in and the restore is started disconnect the power cable. 

If Only this would work…

Here’s what I tried. 12, maybe 15 times, I use the power cable but have tried unplugging it at different times. Before I open iTunes, while it’s “Extracting” while it’s “Preparing” always the same (actually no, I’ve seem some pretty weird errors this way 21, 2005, a couple of times) Always unplugging the USB, waiting 15secs, replugging, waiting 15secs, not trying to Rush anything between attempts,

I’ve tried running iReb (5/6) first but, again, then iTunes won’t recognize the ATV2. For some reason though, the iReb version in iFaith will allow iTunes to recognize the unit (must be an older ver) but doesn’t seem to help either. I’ve Mixed it up, different orders, same result, during the “Preparing” or “Verifying” Error 16XX (usually that #)

Then, after this marathon session, no power plug, no “2-fingering”, just insert the USB, wait, Shift Restore and point it to the Unmodified Restore ipsw and BANG! No Issues, same cable, same everything, it quickly & effortlessly does the restore…

I know it’s gonna work because of that USB “Ding-Dong” I talked about happens, at least two different times, during the “Preparing/Verifying”. This has always let me know things are going as they’re supposed to. It Always happens during the Virgin Restore, it’s Always happened with the other units with the SP restore. This unit does it with the Virgin just Never with the SP.

It just refuses to load the, SP Modded, ipsw no matter what I do :frowning:

I Really Appreciate your help, If you had any other suggestions I’d take the advice and give it a try!

@jamesleber

 

I was on the brink of pulling out my hair and trying all those things you mentioned,but I took a step back.  Here is what I did (note: i am doing this on a Mac with iTunes 11.0.1):

 

  1. Quit iTunes & Seas0nPass

  2. Disconnect Apple TV 2 from power and from the computer

  3. Open Seas0nPass

  4. Right-click “Create ISPW” and choose the firmware 5.0.2 (the last untethered jaiibreak)

  5. When Seas0nPass shows the screen with the two buttons circled in red (i.e.: waiting for DFU device), THEN connect the Apple TV 2 via micro USB

  6. Wait for the light on the Apple TV 2 to flash rapidly (should take about 5 seconds after plugging it in – it will flash slowly at first)

  7. Point the silver remote at the Apple TV 2, hold the two buttons for 7 to 8 seconds (I count off 7 Mississippi slowly)

  8. Release both buttons and set the remote control down

  9. Don’t touch the keyboard or mouse until everything completes (it may interrupt the automated script that starts iTunes and does the restore)

 

If you have done this already, then I apologize for wasting your time, but I was so ready to try every solution I found on the Internet and it turned out my problem was nothing more than having the remote interfere with the Apple TV 2 by unnecessary button presses or pressing keys on the keyboard that hijacked what the automated script was doing in iTunes.

 

Good luck.

For what it’s worth…  I have been having this problem with one of my 3 Apple TVs…  What worked for me is changing to another USB port on the same laptop.   

My advise to anyone having this issue - try a different USB port… if that doesn’t work - try a different computer. 

Good luck.


 

 

I have the exact same problem, and i have done it successfully twice in the past with older os.

 

 

I have the exact same problem, and i have done it successfully twice in the past with older os.