Can't get AVTflash to work

I have followed the instructions, installed ATV flash onto a flash drive the on screen instructions said the process was completed. I powered down my apple TV and inserted the flash drive into the USB port in the apple TV. When the ATV is powered back on the screen is black and then after apporx three minutes it starts up normally, with no firecore logo, no progress bar just normal apple tv with no extra features. I have tried this three times with no success so I decided to start the process again but my PC no longer recongizes my flash drive. I tired the download to reformat my drive but when I try to use it I get an error message that permission is denied adminstrator rights are required to use this tool.

Can anyone help please?

I had the exact same problem. Where you able to find any resolve for this issue? 

I have the exact same problem after following the procedure recommended elsewhere on this site- update ATV to latest firmware- which i did, and now runs 3.0.2.

Yesterday there where no updates available?! today there was.

After update, the ATV simply ignores the usb- and boots normally. I now cant use atv with my NAS anymore - bonkers.
(and the installer doesnt run under Mountain lion- quits saying it cant change to applett mode?).
(Tried to install usb from windows after that) 

If you want to know why i wanted to reflash? Because ATV had become jitty, slooooow and xbmc really unstable, Nito (files) wouldnt start- just say “dink” and then nothing.

You (Firecore) ask me if i want to have lifelong support? hmm, not if this doesnt work anyhow :frowning:

 

regards
Gunni Grahn