Can't get atv2 jailbroken on 5.2

Hi all. I’ve successfully done a jail break twice before on older os, but now on 5.2 i simply can. It get it to work. I’m using the same cable, and incidentally I can easily restore the atv using the original 5.2 ipsw. I’ve tried 3 different macs, all the USB ports on each. Done the usual trick of making sure no ios devices are connected, wirelessly or otherwise, disconnected other USB devices.

I can easily put it in dfu mode, but it just never gets past ‘preparing the atv for restore’. If I use the original file it does the job fine as I stated earlier.

I’m pretty sure I’ve read every trick in these forums so I’m at a loss here.

The first time I did the atv I need to have power cable plugged in too, the whole time and then it worked. The 2nd time (5.0) I didn’t need to.

Now with 5.2, I’ve tried every combination of everything I can think of.

I’m about 7 hours down and feeling the frustration. I’d watch something but…well… I couldn’t be bothered having to convert something first :slight_smile:

Anyone got anything that could suggest? I’d try animal sacrifices at this point. Anyone got a goat or something they want to get rid of.

Well i still couldn’t get it to work, had to go back to 5.02.