Can't download Infuse Pro 5

I purchased Infuse Pro 5 on my iPad and downloaded it there. When I try to download it on my Apple TV (4th Generation, 64GB), I click on the cloud icon, it circles for a few seconds, then the cloud icon returns. I am able to download Infuse 5 (not the pro version) and every other app I try. It only happens with Infuse Pro 5.

I’ve tried everything on the Apple TV. I made sure it was updated to 11.4 (I’d tried both before and after I updated it), restarted it, logged out then back into the App Store, unplugged it for a few minutes then plugged it back in, and switched between ethernet and wifi. I even reset my Apple TV and tried to download Infuse Pro as the first thing in the possibility that it was a space issue, though, as it is a 64GB, I doubt that has anything to do with it.

What also bothers me is I emailed support about this two weeks ago. They responded, made some suggestions, then stopped responding over a week ago. I even sent videos showing the behavior. I just want to be able to use the app I paid for. Please let me know what to do about this.

Welcome to the forum and sorry for the trouble.

Are you accessing Infuse Pro 5 via the App Store search, or through the Purchases tab? It actually should work both ways, but you may try both to see if either works for you.

Unfortunately, Apple doesn’t provide developers with any tools to help troubleshoot issues like these (for privacy reasons we can’t even see that you purchased the app), so if the issue persists your best option may be to get in touch with Apple so they can help. https://support.apple.com/contact