Can't download Infuse 7 for Mac

On my M1 MacBook Air, in the App Store I am trying to download Infuse 7. My problem is there is no download button only a purchased button which is greyed out.

What do I need to do to download it please?

We’ve seen a few reports of this, and haven’t narrowed down the cause just yet.

Is the app listed if you click ‘View My Account’ from ‘Store’ in the menu bar and browse through your list of Purchased apps?

Hi. Thanks for the quick reply. No it’s not listed there. I have a subscription which I use on my Apple TV and iPhone.

We’re still researching why this may happen.

If you have a chance, can you try the troubleshooting steps found here? (this list is from another company who has apps on the App Store)

https://support.omnigroup.com/troubleshooting-mas-downloads/

Thank you James. Creating a new admin account and downloading with that worked for me.

1 Like

Nice “add-on” for PRO users. However, I was a bit surprised that the macOS requirement is Big Sur. Usually third party apps will work on 2 recent OS’s, except for maybe Apple which of course makes sense since their business model is to sell hardware.

I think you will find this is because Big Sur is the only one that supports the API’s and SDK’s that allows them to use a single code base using catalyst without wasting a ton of resource building a dedicated Mac app.

Hi there. I have been downloading builds from the alpha/beta but now want to download the official app from the Mac Store. When I go into the Mac Store it just says ‘purchased’ when I search for Infuse 7. If it then go in my profile to search for the purchased app it does not show up. This happens even after I have uninstalled the build from the link below:

https://community.firecore.com/t/infuse-for-macos-download-links/24330

See screen grabs attached of how the app is showing up in the Mac app store. Can anyone help me figure out how to find and install the version on the Mac App Store please?

Thanks!

I also had the beta and before I installed the version from the App Store I uninstalled the beta with AppCleaner (free and rock solid). No issues after that.

1 Like

Thanks for that. I tried to uninstall the beta app with AppCleaner and after removing it the problem persists with the App Store Infuse 7 just saying ‘purchased’ and then in my profile it does not show up in my purchased apps. Is there anything else I can try? Thanks!

In addition to the steps above which describe creating a new admin user to download the app, there is another workaround which at least one person has reported success with.

  1. Sign out of the App Store (do not sign back in)
  2. Restart your Mac
  3. Browse to the Infuse 7 page in the App Store and click ‘Get’
  4. Log in to the App Store when prompted
1 Like

This method works for me James! All installed now thanks so much! I did have another quick questions. Is there a way to change the MAC App icon to the black version similar to IOS? Thank you, absolutely love the app!

1 Like

Great!

We’ll be looking into options for macOS icon changes for a future update.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.