Can't create Patchstick?

i experienced the same problem i called the company no reply. i am very disappointed. I ordered the usb drive, the order was cancelled. i then spen 50 bucks for the software, that doesn’t work and no customer service.

is this a real company?

Instead of using the drive name ‘/dev/ATV’ you should use the drive number.

The entire command should look something like:

sudo ./createPatchstick /dev/disk4

Just replace the disk4 with your disk number (disk1, disk2, disk3 etc).

If you need support please use the contact form on our website at:

http://www.applecorellc.com/contact.php

Support responses are quite prompt.

Thanks for the response. Your installation docs should be rewritten to clarify the name vs. drive number issue.

Sorry for the confusion. This will be corrected in the new upcoming version.

[list][/list:u]
Instead of using the drive name ‘/dev/ATV’
you should use the drive number.
The entire command should look something like:
sudo ./createPatchstick /dev/disk4
Just replace the disk4 with your disk number
(disk1, disk2, disk3 etc).[/quote]

Note the use of spaces in the terminal command:
sudo(space)./createPatchstick(space)/dev/disk#
Are the command lines also sensitive to caps?
The patch hasn’t worked yet for me, either.
The instructions state “atv3-0”, but I have “atv3-0-1”…
That’s what I typed for the initial sudo.
It went through the process,
then I reset the ATV to factory settings,
updated to the most recent software,
then turned it off, inserted the atv3 patchstick…
and the atv pomptly ignored it
and started up without the patch.
I used one of the USB drives you folks had sent me before,
so I don’t think that the drive was the issue.
Any suggestions?

I initially had a problem when creating my patchstick too. The problem for me (and I’m guessing for some of you) is figuring out the name of your USB thumb drive. It’s not the name that shows up in the Mac Finder. That’s what I initially used and it seemed to create a patch stick okay (I got the successful message), but it couldn’t boot the AppleTV.

To find the correct name to use in this process, go to the apple menu (far left menu with the apple symbol) and choose “About this Mac”.
Click the bottom button titled “More Info”. The System Profiler app will open.
In the Hardware section on the left side, click on USB.
From the list on the right side, find your thumb drive and see what name is given to it.
Use that name in the terminal to create your patchstick.

I can’t create my patch stick.

For those of you who are having problems with this, I found a bug in the createpatchstick script. The script apparently beleives that everyone names their bootdisk OSBoot. The script trys to copy the required boot.efi file from this drive. The only way around this is to edit the createpatchstick script itself and edit the TWO lines that point to /Volumes/OSBoot… to /Volumes/insertyourbootdiisknamehere/… <-this mean you need the rest of the line to stay the same - e.g. only change the text shown…

But I am still having issues… ANY HAVE ANY IDEAS FOR ME? THANKS! :smiley:

basic_folders() {
echo “Copying Files…”
sudo cp -R -P ~/Desktop/aTVflash3-0/atvflash/ /Volumes/Patchstick-root
chown -R root:wheel /Volumes/Patchstick-root

if [ -e /Volumes/[b]OSBoot[/b]/System/Library/CoreServices/boot.efi ]
then
	cp /Volumes/[b]OSBoot[/b]/System/Library/CoreServices/boot.efi /Volumes/Patchstick-root/
else
	echo "boot.efi not found! Make sure you have a mounted OSBoot volume."
	echo "Can't complete process. Exiting.."
	exit 1
fi

}

Yes, I did exactly that- and it STILL didn’t work! What’s going on? Its not like its difficult to type a few simple commands in Terminal… :shock:

Question: In Disk Utility, the thumb-drive shows up as Disk2s1, or Disk1s1, etc…
NOT as Disk2
I tried doing it with Disk2, it didn’t work,
then I tried it with Disk2s1, and it didn’t work…
what the…??? :twisted:

OK, I finally got it to work…
how did I do it?
[color=#FF0000]Magical incantations and ritualistic dances…[/color]

seriously:
I got the 3-0-1 update, and for some reason it wasn’t working
so I renamed the “ATVFLASH3-0-1” folder on my desktop
to “ATV3-0” and in terminal did
cd DESKTOP/ATVFLASH3-0
(as originally instructed)
and then it seemed more happy.

In the next step, I did the
sudo ./createPatchstick
without a problem, it asked for my password, as per instructions.
Then, I did the
sudo ./createPatchstick ./dev/disk1
(instead of the name of the stick in the finder-
I looked in the Disk Utility,
and simply used the Diskname under the drive’s “Finder” name

and finally it worked…
yey-
but, :evil:

truth is: I had to spend WAAAAAAY too much time on this,
if the instructions had been clear, and correct,
it would’ve been done in less than 5 minutes,
as it should’ve been…

You should not change the install script at all. The OSBoot Volume it is referencing is an additional file that needs to be downloaded. It is under step #1 in the instructions.

Your flash drive can be named whatever you like, as the command to run the script uses the drive number and not the name. The correct command should be something like.

sudo ./createPatchstick /dev/disk3

Just replace the ‘3’ with your disk number.

Guys, guys. You really need to read the instructions CAREFULLY. I don’t even have a Mac, had to borrow someone else’s, and have almost zero experience using one, but it only took me about 5 minutes to figure out how to do everything. The instructions describe, step be step, exactly what needs to be done, and everything I’ve read in this thread, at least to me, seems to be addressed 100% in the instructions.

Now, I’m not giving a free pass to aTV, though. I’m still not successful in updating my AppleTV, but those are other issues out of my control. I will, however, give them a little credit for finally creating a support forum. So at least now the company can address some user issues, and people don’t have to go all over the web looking for information. The problem I’m having has been discussed in the MacRumors forums. I’ve also been corresponding with a representative at aTV about my issue, and for the most part they’ve been responsive. It’s still not resolved, but they’ve been responsive.

I get the message “There do not appear to be enough arguments for the number of partitions you specified…” every single time.
I’ve spent an hour and a half on this… way too long.

Please help!

What operating system are you using?

Hi,

I have Mac OS 10.5.2 Leopard. Is it possible for me to create the patchstick using your instructions ?

I read on other foruns that it isn’t possible to create patchsticks on Leopard…

If it isn’t, how should i do it on Windows XP or Vista ?

Thanks

Yes, our software is compatible with both Tiger (10.4) and Leopard (10.5).

here the step by step lowdown!
change directory in the terminal window until you are in the ATVFlash3-0 directory. confirm this by the ls command.
type: sudo ./createPatchstick
this will list the drives on your system incl. the thumbdrive.
example:
Listing available disks:
/dev/disk0
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *298.1 Gi disk0
1: EFI 200.0 Mi disk0s1
2: Apple_HFS Macintosh HD 297.8 Gi disk0s2
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *973.8 Mi disk1
1: Apple_HFS Patchstick-root 973.8 Mi disk1s1

before you proceed you will probably have to edit the createPatchstick file. i always got the cannot find boot.efi error before i fixed this.

here is what worked for me:

if [ -e /System/Library/CoreServices/boot.efi ]
then
cp /System/Library/CoreServices/boot.efi /Volumes/Patchstick-root/
else

type: sudo ./createPatchstick /dev/disk1 “comment: insert YOUR thumbdrive number here. be REAL CAREFUL!
or you will screw up your OSX installation!”

response:
Are you sure you want to partition disk /dev/disk1? [yes|no]yes

Partitioning /dev/disk1:
Started partitioning on disk disk1
Creating partition map
Formatting disk1s1 as Mac OS Extended (Journaled) with name Patchstick-root
[ + 0%…10%…20%…30%…40%…50%…60%…70%…80%…90%…100% ]
Finished partitioning on disk disk1
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *973.8 Mi disk1
1: Apple_HFS Patchstick-root 973.8 Mi disk1s1
Patitions done.
Copying Files…
Changing Patchstick-root to Apple TV Mode…
Unmount of all volumes on disk1 was successful
/dev/disk1s1 removed
Unmount of all volumes on disk1 was successful
/dev/disk1s1 added
Unmount of all volumes on disk1 was successful

Your disk /dev/disk1 is now unmounted and ready to patch your AppleTV.
Enjoy… :slight_smile:

You should not change the script at all. Just make sure you have downloaded, and opened the file under step #1, and you will not receive any errors.

Also, reiterating the importance of using the CORRECT disk number for your installation. /dev/diskN - replace the ‘N’ with your disk number.