Can't connect Infuse Iphone or Apple TV to my Macbook

In November 2023, I couldn’t connect to the Infuse app on my Apple TV. After two weeks, I realized it was my VPN. I had to disable it every time I wanted to use Infuse on my Apple TV.
For the past week, I’ve had the same problem, no matter how hard I try to disable my VPN, reset file sharing and follow the Infuse tutorial. I still can’t solve the problem.

Can you please help me?

There are a few things to check.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

Also, if you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again. You can also try one of the tips found here. FileBrowser Connection errors connecting to your Mac OSX

This also may be related to an Apple bug as there are others reporting issues here.

There are some suggestions posted in that thread, and they basically entail.

  • Turning off/on File Sharing
  • Disabling the Firewall in macOS settings
  • Disabling all VPNs

Hello,

Thank you for your attention and your feedback!

SMB is enabled.
My user profile is selected under file sharing in the advanced options.
Disk folders are shared. I’ve even tried sharing the entire hard disk, but it doesn’t make any difference.

I don’t understand this step:

The username is the password selected in infuse and must be the same as the one for my iCloud because if my username is different from my iCloud, I no longer have access to my iCloud and cannot synchronize with infuse.
Do I need to create a second iCloud account?
As you say, I think this is due to a change in their OS system following an upgrade to my MacBook Pro.
Furthermore, after trying to add an additional user name, to no avail, the local host name (example.locale) is the same for all users, so in my opinion this doesn’t change the problem. I’d like more clarification on this point, please.

Also, I don’t think that’s where the problem lies, as infuse has always worked before with the same iCloud username.
Your idea that it comes from an Apple update seems the most obvious to me, as I haven’t changed any of my settings between my last use and today.
If this is indeed coming from their update, should I wait for an infuse update?

Here’s my setup for further investigation to find a solution:

CPU: Apple M1 Max
Operating system: SONOMA 14.4.1 (23E224)

For the final checks, following a lot of reading on various platforms including the discussion forum

I’ve deactivated and activated file sharing
Disable firewall
Disabled or even completely uninstalled my VPN

I still get the same message:

An error has occurred, sorry, infuse has encountered an error trying to connect

I hope you enjoy this point-by-point feedback.

In the hope of finding a solution for me and the community who are in the same situation as me.

Sincerely