Can't connect AppleTV to iMac - FRUSTRATED

I’ve used Infuse for years but I can’t get it to connect anymore.

Recently, the app started intermittently saying it it couldn’t find my media share (SMB to hard drive attached to my iMac). I checked the iMac sharing settings and nothing had changed. Nor had I changed my username/pw or machine name.

So I deleted Infuse, restarted both the ATV and iMac, and reinstalled Infuse. I re-entered all my credentials and I just get the same no information message as before “Infuse encountered an error while trying to connect”

Any ideas on what to try now? Beyond the steps above, I also tried changing the SMB type but that didn’t help. Infuse version 7.4.2(4192) tvOS version 15.5.1 MacOS Monterey 12.4

UPDATE - I noticed that in Infuse I see my Sonos device but not anything related to the iMac file shares. I tried VLC and also did not see my iMac share. Is there any other SMB setting I can check or change?

I’m very frustrated as the error message is terrible and doesn’t help to narrow down the issue.

Welcome to the forum and sorry you’re having problems.

With VLC also not seeing your Mac it sounds like either a Mac setting or network issue. How are your Mac and ATV connected to the network? Ethernet or WiFi? If WiFi what band, 2.4 or 5?

I know you said you check the settings but sometimes folks overlook one or two so could you check the settings referenced in the users guide?

Also make sure that your sharing settings on the Mac didn’t get reset during a security update.

Can you connect to your Mac with any other devices? If so what protocol?

Really appreciate the feedback but no luck.

I rebooted both devices again. I re-re-checked the iMac file sharing settings and SMB is on with a user (me) set up for Windows file sharing. I even looked in other places that I thought might be related like privacy and my NTFS app but I didn’t see anything relevant.

I can connect to the iMac using Plex from the same AppleTV and it works fine. I can also connect to it using AirDrop from my phone.

I’m connected via Wifi dual band Eero mesh router (using 5Ghz).

So much for Apple and “it just works”

This info may help also.

See if this might help: SMB access dropping

Thanks but so far it hasn’t worked and I’m not sure if I’m entering the static IP correctly in Infuse. I tried just the IP address and the IP address with with SMB:// as the protocol. Neither worked.

As a retired IT professional, I’m at a loss. Usually, I can find a way to make things work. And in this case, everything was working fine and suddenly stopped working. I had not changed anything on my router, AppleTV, nor iMac.

This just doesn’t make sense to me.

I decided to test the connection to my iMac file shares from my iPad using Infuse. It worked immediately and the SMB connection was visible when I opened the app.

So clearly the problem is not the iMac or the SMB shares but is instead something that’s not working right on the Infuse AppleTV client. The AppleTV can connect and use file on my iMac using Plex. My iPad can use the Infuse app to access the SMB shares on the same iMac. So the isolated fault as I see it is the Infuse app on AppleTV.

Well since neither VLC nor Infuse can see the SMB share I’m still leaning to a network issue possibly with the ATV. Have you checked to make sure both the ATV and the iMac are on the same WiFi band?

I have seen one other oddity with the Mac networking, when you try to use the network name of the iMac did you use the name ending in .local or the .home? For some reason, Mac shows both on the same panel but they have SMB using the “.home” suffix.

I don’t know if this matters but I know in the past it’s caused me problems. That’s why I ended up setting a fixed address for my mac and used the IPv4 address given in the WiFi network panel under TCP/IP on the iMac Settings.

Since you have the iPad working with Infuse do you have iCloud sync turned on in Infuse on the iPad?

If so, you can try an experiment if you’re up to it. After the iPad finishes its icloud sync (you can monitor that on the “Library Settings” and it should say something like last updated… then do the following.

Delete the Infuse app off of the ATV. That will get rid of all settings.

Redownload it from the app store and when you get it back on the ATV launch Infuse again but DON’T add any shares, instead, go directly to settings in Infuse and then to Library, it should show something like syncing to iCloud on the left side.

Just let it go at this point and it should get the share info from the iPad icloud sync and then connect to the iMac. This could take a bit so don’t get frustrated if it sits on syncing for a while.