Can't boot ATV2, Unable to upload iBEC!

I used my ATV2 for years with much pleasure. I think my ATV2 is on 5.3 but i’m not sure because i haven’t updated it for awhile cause it was working great. There were moments that the power was disconnected from it and i could always tether/boot it again with Seasonpass. Wit various versions of it, never had a problem with it.

A few weeks ago, the power was disconnected to the whole house block here. Also to the ATV2. Tonight i wanted to boot/tether the ATV2 again and it didn’t work. I only got to DFU mode and it got stuck there. Seasonpass recognized the ATV2 but got stuck in “found device in DFU mode” and furthermore did nothing. When i held play and menu then again for about 7-10 secs seasonpass started uploading iBSS. That wet succesfull. After that upload iBEC! and that is where it fails continues. Every time i get the error “unable to upload iBEC”.

I tried various versions of Seasonpass but no luck. I have really no idea whats going wrong.

Can someone please help me ? I am on a MBpro, El Capitan 10.11.

thanks in advance, you would help a lot…

Greets Erwin

PS not sure if my first post arrived well, so tried it again…