Cannot use domestic SRT on ATV4K

I’m using ATV4K with Infuse 5 Pro. Despite having the SRT file and the MKV file with the same name in the same folder, when I try to play the MKV file, the local subtitle SRT file was not used (under the subtitle menu it shows “None”) and I could only use the “get more” function to obtain subtitles files from

My MKV file and SRT file are both stored on my Synology NAS, which is currently connected to ATV4K (in Infuse) using UPnP.

Grateful for any insight/areas which I could further look into. Thanks!

Unfortunately, external subs won’t be available when using UPnP or DLNA sources.

An alternative option would be to connect directly to your source via SMB or NFS. Doing this would allow the subs to be seen.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.