Cannot see menu after installation, blank page

Installed ATV Flash and i did it correctly, it started up normally but the screen went black when it went to menu. I could still hear it as i clicked buttons and the screen saver would still come up. I have reinstalled it and restarted it but still nothing… any ideas ?

I have this problem to, well sort of. If I disconnect the HDMI lead and replace it the menu screen come back on.
This is a real pain but can’t work out if its a atvFlash thing or an apple one.
I’ve seen mentioned to turn off the screen saver and set the output to 720p, I did this but still no joy.

Can someone help?

Which version of AppleTV software are you running. 3.0.2 supposedly has a few fixes for issues such as this.

I restored my ATV to v2 and tried it with four different HDMI leads into all 4 HDMI sockets on my 1 year old Samsung tv. ATV was outputing 720p and screensaver was altered between on and off.
I then upgraded it to v3.0.2 and tried again with all the leads and sockets.
Every time I would get it to connect but after a shutdown or channel switch I had a blank screen but could here the button bleeps. If I took out the lead for a while and reconnected it it was ok so long as I didn’t do anything else with the TV!!!.
One odd thing in version 2 was that even though I had a blank screen the screensaver would work but when I pressed the menu key on the remote it went to a blank screen.

I should have mentioned I had a Samsung TV.
Have now found this which has cured my problem, it may help others