Cannot recognize folder with periods in name (iOS 17)

My file structure:
/Movies/The.Avengers.2012.2160p/The.Avengers.2012.2160p.mkv

The movies could be recognized before.But now,when I add “Movies” folder to the file library,Infuse can’t recognize every mkv file in folder with periods in its name,"Empty Folder"on the screen.
If I replace periods to spaces,the movies will be recognized again,but it will be a huge project.It’s weird,they obviously could be recognized a few months ago even periods in folders’ names.

I don’t know the reason because I didn’t open the App for months,it happens after I updated to iPad OS 17 and Infuse 7.6.2.
BTW,I use the local extended storage.

Could you provide a screen cap of your file names and structure on your file storage device just in case there’s a hidden gotcha?

I didn’t change the titles of these folders and mkv files…They could be recognized a few months ago before I updated to iPad OS 17 and the latest Infuse.And they will be recognized again if I replace the periods in folder titles to spaces…

Maybe the latest Infuse treat letters after a period at the end of a folder’s name as a file extension in iPad OS 17 …I don’t know…

I had the same issue and added a space on the end of the folder name, for some reason anything with a period it sees as a file extension, this was only affecting infuse on iOS.

Hi All,
I Started to notice a bug on my new iPhone15 Pro running the latest infuse 7.6.3 (4619) related to adding local folders.

I used to have a pendrive loaded with media ( TV Series and Movies ) that worked perfectly on my previous iPhone14:
Add Files → Saved Share → Add → Add Local Folders and then select the external drive.
After done that in Infuse → Files, I was able to see the external drive and browse and watch all the media.

Now with my new iPhone15 and the latest version of Infuse when I do the above I end up with only a small portion of folders listed and going to the only folders I can see I am left with a laconic empty folder. This happen for every folder are visible and again, it’s just a small portion of the true media folders I have in the drive.

Instead if I go to Apple Files and the to the external drive I can see all the folders & files and if I try to open them with infuse, infuse ask me the usual Play / Save / Play & Save etc. and after clicking on Play the file plays correctly.

This tells me that I don’t have issues with the external drive per se but somehow Infuse is no longer able to correctly scan the external drive folder I selected.

I leave few screenshots and I am happy to provide any further information if needed.

Thanks




Just for completeness when it was working I was using iOS16 and now I am on the latest iOS17.

Thanks

As suspected and mentioned before, I created a script that recursively strip out periods ( dots ) from every folders leaving instead the media files as they are with dots in it.
Now magically all folders and files are correctly scanned and seen by infuse when I attach the external SSD, Tv Series with seasons, movies etc.

@james this is definitively a bug and it would be much appreciated if it can be acknowledged and looked into it at some point.

Thanks

Has Infuse ever officially supported a plethora of periods in the folder name?

@Hitsville Absolutely Yes, since at least Infuse 4 ( and probably even before ).
This change happen only recently ( I am not sure if it is related to the latest version of Infuse 7.6.3 or to iOS17 ) and it might be just a bug unless told otherwise.

I was referring to officially being supported in the metadata 101 documentation, rather than whether they previously worked?

@Hitsville according to the infuse documentation ( Metadata 101 – Firecore Support ) dots are officially supported

This thread has been marked as “Researching”

1 Like

This should be resolved in today’s 7.6.4 update. :slight_smile:

Thanks for your patience.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.