Cannot Play VideoTS files with aTV version 3.3.2

I have version 2.2 of AppleTV and version 3.3.2 of aTV. I get an error (“An error occurred. Press Play/Pause to restart your AppleTV”) when trying to play movies that are encoded in the VideoTS format. They work fine on my mac so I know that the rip was done properly. I get to the play movie button and when I click it, I get the error.

Please let me know if you can assist me. This was the primary reason for purchasing aTV.

Thanks,
Scott

You might think about running the nitoTV smart installer, and changing the DVD playback mode to Quicktime. This will greatly enhance the DVD playback experience.

Nito TV smart installer:
http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

Change playback mode to Quicktime:
Located in: DVD > Settings > Playback Mode

Hello,

I face the same problems like “The Pink One”.

In 3.3.1 everything worked fine - after updating to ATV 2.2 and ATV Flash 3.3.2 I receive the message “An error occurred. Press Play/Pause…” whenever I try to start a TS-file. The finder shows the usb-drive, I can access it using cyberduck but I cannot play any TS-file.

I have installed all codecs
I have switched over to Quicktime playback mode
I have the right display mode
I have run the smart installer
I am using the same options as in 3.3.1

So what’s wrong and what can I do - please advice

-Nick

Hi,

Same problem here.
I’ve sent an e-mail to the tech support.
They linked me back to the nitoTV page on wikipedia, which isn’t really handy because it is all but self-explanatory.
But, after readint it through, I think I’ve done everything properly, as I ran the Smart installer and got the following message “Installation was a success”.
Cool.
I transferred a DVD folder to the “Movies” folder.
I can see the DVD folder in the “Files”.
But it simply refuses to play.
I hoped this was because I did not unplug the AppleTV after running the smart installer…
But unplugging it did not fix the problem.

All I have is :

  • either a black screen with no sound
  • a menu that indicates the DVD folder and offer “Play files” as an option… but nothing happens when I select it.

As the viewing of DVD’s with menues is the only feature I’m really interested in, I think I will ask for a refund.

Regards.

FRED

A few things you will want to check.

  1. DVD > Settings > Playback Mode is set to Quicktime
  2. If you have menus in your DVDs, make sure you Enable DVD Menus in DVD > Settings

Hi,

Thanks for your answer.
But obviously, I did that already.

So as for the others, the problem seems to be elsewhere.

I am suspecting maybe a too highly set tresolution. I’ll try to lower it down to 720, or even 576…

If that does not work, then there is definitely something that does not work…

Regards.

FRED

To aTV Flash:

Could you please provide an answer to my request, also?

Thanks in advance!

-Nick

PM sent

i’m in the same boat. i believe i’ve followed all recommendations in this thread. my story is a bit different, though, and may shed some light on my situation:

i downloaded and installed the current version of atvflash on october 11. after a bit of bumbling about i was able to play media in video_ts folders across the network sitting on one of my macs. this worked for several days without much problem.

today, after getting part of the way through a particular title, i hit the menu button and the movie kept playing. i hit it several more times, and play/pause as well, and eventually the atv appeared to restore itself from a backup - apple logo with a progress bar just below it.

following that, i no longer had dvd/xbmc on the menu. after a few reboots and head scratching i finally just booted from the original atvflash and rebooted as i did the first time. the network configs, including smb mount definitions, are untouched. i am able to navigate to the mac and see the video_ts folders just as before. but now, i have the same issue as described previously in this thread when attempting to play from one of these folders:

/!\ An error occurred.
Press Play/Pause to restart your Apple TV.

please help me get out of this hole; this capability was the reason i purchased atvflash, and indeed, the appletv. without this capability have no need for either.

latest:

  1. factory restore.
  2. atv update
  3. atvflash install
  4. smart install
  5. reboot

at this point, i’m able to navigate to the known good video_ts files but pressing play seemingly does nothing. however, pressing play a second time brings the apple logo again. i believe this is the same as the failure prior to the rebuild, except the error telling me to press play/pause to reset the atv isn’t showing - after all, when i press play/pause that’s exactly what happens.

please help me pull this thing out of the toilet.

A few settings you should check.

  1. DVD > Settings > Playback Mode - Set to Quicktime
  2. If you DVDs contain menus, enable this option in DVD > Settings > Enable DVD Menus - Yes

Hi,

i am new to all this so this is my first post.

i have dragged a video_ts file from a DVD, dropped it in a folder via Cyberduck. Took about 3hrs to upload. I then tried to play it (using Mplayer and Quicktime. Both times the image just kept breaking p.

PS. Is there any type of user manual available for the ATVFlash?
PPS. I ordered my pizza last night and it still hasn’t arrived. How long do they take to deliver to Australia?

A few settings you should check.

  1. DVD > Settings > Playback Mode - Set to Quicktime
  2. If you DVDs contain menus, enable this option in DVD > Settings > Enable DVD Menus - Yes[/quote]

i don’t pretend to understand why, but enabling dvd menus seemed to have worked. this is particularly confusing for me because the dvds in question do not in fact contain menus. thanks for making me look in that direction.

unless you know for a fact otherwise, your dvd is most likely encrypted - and dragging/dropping the files won’t get you very far.

Good point. How do I get around this problem

Paul

You have to use “questionable” software like MacTheRipper to remove the encryption. But you will be breaking the licensing and the DMCA and any other legal thing that have to do with breaking any type of encryption. Even after saying all that, I believe it is actually legal to “backup” one copy of a DVD for “personal use.”

You could also use Fairmount:
http://www.macupdate.com/info.php/id/27162/fairmount

This will mount a virtual image file of the DVD on your Mac desktop, you can then simply drag-and-drop the VIDEO_TS folder using the finder and the resulting copy will be a decrypted one made on-the-fly. All menus, soundtracks, bonus content is preserved. I don’t know the legal status of this software. Hope it works for you.