Cannot Jailbreak ATV2 (iOS 5.1) - Tried Various Methods

I recently purchased an Apple TV 2 and it came with iOS 5.1. I have since tried a number of jailbreaks, and every single time I get the following iTunes error:

 

“The Apple TV “Apple TV” could not be restored because the firmware file is not compatible”

 

The error is displayed straight away, as if iTunes doesn’t even load the file or anything.

 

Things I have tried:

  1. Factory restore using iTunes (completes successfully)
  2. Used various usb cables and so far 3 computers
  3. According to iReb the ATV does go into pwned DFU mode, but this can only be achieved with the power and usb plugged in. No amount of fiddling, removing the power cable at this time or that time, will allow the ATV to be powered up with just the USB cable alone. I don't know if it's something to do with not being in the US and using 220V power or what.
  4. I'm currently using Seas0nPass to build a custom ipsw file (and the automatic restore fails, so does shift+restore)

 

I’m sure someone has probably had this issue and I hope it’s a simple fix. Any replied will be appreciated.

 

Just posted a new topic: http://forum.firecore.com/topic/7624

Try that.

Thanks for the link, but I have a problem with this part:

 

“Once complete, iTunes will automatically launch and the script will automatically restore the device, uploading the jailbroken iOS firmware”

 

iTunes launches, but the restore is immediately halted with the above error message, about incompatible firmware.

 

Also to clarify, were you able to get into DFU mode using only a USB cable (i.e. no power cable). I have purchased another USB<>Micro USB cable and will try that out tonight.

What firmware are you running on your ATV2? It’s best to update to 5.1 before you do anything.

Hi to get my atv2 into dfu I have to have the power cable in aswell. So once ireb says it is in dfu mode unplug the power cable. then reopen ireb and click to put in dfu mode, follow instructions to put in to dfu. You now have atv2 in dfu with no power cable plugged in. Workseverytime for me, had my atv2 for over a year