Cannot install XBMC in aTV Flash (black)

Hi Im from German. i Hope you can help me.

I make some screenshots whit the Failure. What does it means ???[[wysiwyg_imageupload:131:]]

[[wysiwyg_imageupload:132:]]

the same here, fresh jailbreaked and installed aTV black…

Here the Manuell Installation. the same problem:

Unpacking org.xbmc.xbmc-atv2 (from xbmc-20111222-22ad8e4-master-atv2.deb) …
dpkg: error processing xbmc-20111222-22ad8e4-master-atv2.deb (–install):
 failed in buffer_write(fd) (7, ret=-1): backend dpkg-deb during `./Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/backgrounds/appearance.jpg’: No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe: 13)
Errors were encountered while processing:
 xbmc-20111222-22ad8e4-master-atv2.deb

Can you double-check the version of Seas0nPass that was used for the jailbreak?

Also, check the AppleTV version in the Settings --> General --> About menu.

Apple TV Software = 4.4.4 (3330)

Seas0nPass Version 0.8.0 (320)

AppleTV2,1_4.4.4_9A406a_Restore.ipsw (Firmware Mac Documents)

for me it’s season pass Version 0.8.0 (320) (just downloaded) and the AppleTv version 4.4.4 (3330) btw the ATV 2 runs also in german :wink:

I checked the space with df:

/dev/disk0s1s1          630048    596168     27584  96% /

devfs                       26        26         0 100% /dev

/dev/disk0s1s2         7152352    251712   6900640   4% /private/var

I just found this link (http://forum.xbmc.org/showpost.php?p=917606&postcount=31) but I’m not sure if I want to set new symbolic links :frowning:

 

 

 

I found this link too, and now i try and it works …

I dont understand this steps, but ok … :wink:

Copy and paste

So far I understand, this creates a directory called Application on the more and less empty partition of the ATV2  and then it moves all the file of the original /Application folders on from /dev/disk0s1s1 to the /dev/disk0s1s2 and then creates a symbolic link from the original place to the new folder. As I wrote before I don’t want to do to much changes to the file system. In the last version I used before the iOS5 came out, it works more and less seamless. 

Because it’s late, I will go sleep and looking forward  for an answer from James or another supporter…

Have fun,

Leif

I was having the same problem with failing installations of XBMC on 4.4.4 (3330). I read the post above with the link: http://forum.xbmc.org/showpost.php?p=917606&postcount=31

I followed the steps on the instructions (with minor changes to connect via ssh). After doing that, I powered the device off, then on, and then went back to Maintenance, Manage Extras and install XBMC. This time the installation was succesful!

Everything else stayed the same.

Cool. Thanks.

Yes, it sounds like there is something fishy going on. If you’re seeing this issue please open a support ticket and attach your Seas0nPass log file so we can work to track down what’s going on. Even if you’ve already resolved the issue, sending in your log file would be helpful.

Mac log file: SP_Debug.log (locate by selecting the ‘Show Log In Finder’ option from the Seas0nPass --> Help menu)

PC log file: /Libraries/Documents/My Documents/Seas0nPass/Seas0nPass.log

Hi James.

I did a request, also it works for me now because I also follow the instructions I posted before. 

Happy new year,

Leif

Thanks. We’ve tracked down the issue and included a fix in a new version of Seas0nPass (0.8.1) that was just released.

Re-jailbreaking with the new version (or following the steps found here: http://forum.xbmc.org/showpost.php?p=917606&postcount=31) should cure the issue.

 

Question:  Even though I resolved the issue using the patch that was posted on this thread, should I jailbreak again with the new release…?  Did the folder/partition structure change in a way that it would be beneficial to do it again?

 

Thanks.

 

AWESOME!!! Cant wait to get home to try it!!!

 

AJ

The Seas0npass listed does NOT have the updated version. I just checked and the modified date is 12/30

Can you help figure this out, please? I’ve forgotten the steps to change the links and such, and the xbmc forum is down for me right now.

I downloaded a new version of Seas0npass today (around 12h ago) and it works for me well. Thanks to the support. @andsoitgoes the XMBC forum works for me but here are the instructions:

ssh root@apple-tv mkdir -p /private/var/Applications cd /Applications mv * /private/var/Applications cd / rmdir /Applications (This won't delete unless the directory is empty...) ln -s /private/var/Applications /Applications cd apt-get update apt-get install org.xbmc.xbmc-atv2 wget http://mirrors.xbmc.org/nightlies/da...aster-atv2.deb dpkg -i xbmc-20111020.bc49ac0-master-atv2.deb

Strange. Downforeveryone reports xbmc.org to be down. It WAS up an hour or so ago.

And I downloaded Seas0npass about 2 hours ago, it doesn’t work.

I’m trying the steps, thanks for that :slight_smile:

You know what, I was probably getting an error because xbmc is down.

yes, since xbmc is down, install fails however use OpenDNS name servers on your router or appletv to get xbmc working again.

Yes same here, xbmc.org is down so just hang in there 8)

EDIT: XBMC.org is now accessible but it will still not work for me. :frowning: