Cannot install Media Player

Did fresh Jailbreak with latest Seas0nPass, all other ATV Black features installed except Media Player. Follow message in log file

 

E: Broken packages

ts…

Building dependency tree…

Reading state information…

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The folloinwg information may help to resolve the situation:

 

The following packages have unmet dependencies:

com.firecore.media: Depends: com.firecore.libafpclient (>=1.2-18) but it is not going to be installed

Depends: org.xbmc.xbmc-seatbeltunlock (>=1.0-4) but it is not going to be installed

Reading package lists…

Building dependency tree…

Reading state information…

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

 

Did a killall -9 AppleTV in Terminal, same result.

 

Any direction greatly appreciated.

 

Thanks,

Todd

 

I’m having the exact same problem. 

+1 for me with the same problem.

4.4.4 freshly untethered and jailbroken, and ATV Black 1.1.1

edit - The solution that worked for me (in case it helps anyone else)

ssh into your atv as root (if you don’t know what the root password is, then you shouldn’t be doing this)

cd /var/lib/apt/lists

rm lock 

apt-get update

 

There was a stale lock file in there which was preventing apt from getting up to date sources which was causing failed dependencies.

Can someone from Firecore provide an ETA on a resolution for this issue. I suspect there are many of us experiencing this who, in fact, aren’t inclined to SSH into our ATVs. Thanks.

That worked for me too!!! Thanks a million michael08

The fix worked for me also, thank you!

Thanks a lot!!11!! That worked for me too. 8)

+1

Yes for me, too.

Another +1, removing the APT lock worked for me too.

can you help me please step by step… thanks

 

The step by step was above:-

 

"ssh into your atv as root (if you don’t know what the root password is, then you shouldn’t be doing this)

cd /var/lib/apt/lists

rm lock

apt-get update

 

 

how can I do to acces in my ATV?? with SSH?? I must “delete” some file or “rename” it?? Sorry but I’m not an “Hacker”… thnak you so much if you help me!!

 

thanks

If you own a mac use the terminal programm with following command ssh root@<ip-adress of your ATV> then enter the password when asked. Follow the instructions in this thread. That worked fine for me.

If you are a windows user download a freeware ssh client to do the same. If you don’t know the root password of the ATV, just ask google ;-).

Happy new year with a working ATV

 

 

 

 

Don’t post crap like this, we’re all having enough trouble as it is trying to get this to work. It’s not difficult to follow instructions but we can’t very well follow them if you don’t provide the information necessary in order to do it.

For the next person that reads this and has to waste time googling for the info the password is alpine.

I’m sorry but it really pisses me off when people do this. I do appreciate your help though.

Worked for me too, I used putty to SSH then did the update.

 

Thanks

Mate, it was a standard “don’t blame me if you fuck it up” post preventing people who are inexperienced from destroying their ATV and then telling me I gave them the wrong details.

If you did manage to find the password on your own, then great, it means you have more than 2 brain cells to smash together and are more likely to not destroy your ATV with the wrong command which is very possible as root.

It’s unfortunate things like this piss you off, but remember, I could have been a real prick and said “I fixed it on my own, thanks” and left it like that without telling anyone how to do it.

I just bought Seas0nPass and  aTVFlash (black) … jailbreak fine done, Nito TV runs,

but …I can’t install the Mediaplayer, XBMC and Last FM.

sorry, I have no programmer skills!

Could you please fix this.

Tanks

Chris

There was an updated version of SeasonPass released yesterday that fixed issues with installing some packages (such as XBMC) so it might be worth grabbing tht and starting again as that could well solve your problem?

Note that if a 3rd party package (such as XBMC) has its install broken for any reason (other than the jailbreak itself being the cause of the problem) then this is outside FireCore’s control - you need to wait for a fix from the package maintainer.

 

Thanks for the reply, but sorry this is the version I installed.  :frowning:

Got it … Restarting did the trick :)