Cannot index all contents after adding SMB shared folder

I use a 115 cloud disk, SMB sharing! There is no problem with the naming rules. The movie is named: “movie name (year)”, and the infuse version is “7.1.2”. After I link to the shared folder, I can basically only scan half of the resources: there are more than 600 cloud disk movie resources. Only 300 resources can be scanned. Please tell me what is the reason for this, or is there an error?


Can you try browsing the share via the Settings > Add Files > Share Name screen to see if the missing items are listed there?

This will list all files accessible by Infuse, even things that aren’t supported like images and PDF files.

Yes! I just checked it according to the method you said, and found that I still couldn’t find the missing video resources! But I moved the missing video to another empty folder in the cloud, and then added the file source in infuse, and it can be recognized again. What is the reason! :cold_sweat::cold_sweat::cold_sweat:

It sounds like it may be related to a setting/permission issue with the cloud service?

Are you able to keep the files in the new location? If so, that may be a solution since it seems to work.

This operation is indeed effective! But I have a lot of cloud resources, and there are more than 5,000 resources that are not indexed. If I do this operation, it will be very troublesome and time-consuming, and it is almost impossible to complete! I don’t know if this is a small bug of infuse, I want to know if there is a better solution! Hope you can help me!

You can try adjusting the SMB version in Infuse (under the share’s settings > Advanced tab) to see if this has any impact on what Infuse is able to access.

Sometimes a device may work better with one version of SMB over another, so it could be worth trying SMB2, SMB1, and Legacy.

Hello James!
I seem to have found the problem. There cannot be too many video resources stored in a single folder, otherwise it will not be fully recognized. If I try to store 50 in a single folder, some resources will not be recognized (you can test it), so I Now it is normal to put 39 videos in one folder! Although this can be solved, you need to create a lot of folders, but this is very different. I feel that you need to fix this problem. I hope you and your team can deal with this problem later. Thank you!

I think it must be a 115 cloud disk issue since I have several folders with 300+ videos and a few with over 500 and Infuse has no problems finding them all.

Is the 115 cloud disk a device you have on your local network like a NAS or is this a remote storage you access over the internet? I tried to find more info on this but could find nothing I could read due to a language barrier, sorry.

Hello! I take the liberty to ask you, are you using cloud storage or local NAS? If you are also using the cloud, I think it should be the 115 cloud disk problem, thank you for your answer!