Cannot get Library to categorise TV / Movies

Hi all

I realise there are a few other posts about this type of issue, but I’ve read them and tried the solutions, but nothing is working for me.

On ATV2 with the new version that includes the Library system, I cannot get Movies and TV shows to be categorised properly under the library. Everything is just showing up under the “Other” section.

I’ve set the media type of the specific folders on the shared path, and have tried re-scanning and re-adding the shares a couple of times without any success.

Has anyone experienced this or does anyone have an idea of what I could be doing wrong? 

Thanks for any advice!


Same problems here. Movies are properly displayed but TV shows only show up under “others”. Folder path is marked for TV Shows and metadata are correctly assigned. Is there anything else to take into account like a special structure of naming the files?

Can you provide a few examples of how your TV show files are named?

You may also try correcting metadata as described here.

Ok so my folders are set up like so:

Shared drive: “”

Which contains two folders, “Movies” and “TV Shows”.

The TV show files are in a structure like “TV Shows/30 Rock/Season 6/30 Rock S06E01 HDTV XviD LOL/30.Rock.S06E01.HDTV.XviD-LOL.avi”

Most shows are in a similar folder path. Could the problem be the extra folder there for each episode? Perhaps I need to move all the .avi files into a single folder for each season?

Thanks for the help!

I have very similar problem (maybe the same). I also have 2 folders (Movies and TV Shows) in which there are other folders with movies or shows.

When I added the two folders to the new library, it scanned everything (mostly correct), but I still have few movies and some tv shows in “Other”. However, their metadata are correct (I think). For example there is the Kung Fu Panda 2 movie. It downloaded the cover art correctly and shows correct name or the TV Show Don’t Trust The Bitch in Apartment 23 - it shows the correct name and number of the episode but it is in “Others” instead of TV Shows.


EDIT: solved - wrong naming - for example the file “Don’” should be “Don’” according to The same was with everything others…

OK so if anyone is interested, I managed to get this working. The problem seemed to just be the file naming conventions.

I used FileBot ( to rename all my stuff to a more simple/common format which is supported by lots of media players like XBMC etc.

I used the convention “ShowName/Season 1/ShowName - 1x01 - EpisodeTitle.avi” and the Library system seems to be much happier with that.

FileBot handles movie files too, which also appears to work well now on my setup.

I used Filebot to properly name Mission Impossible 4. This is what it suggested:

Shared Volume/Media/Movies/Mission Impossible - Ghost Protocol (2011)/Mission Impossible - Ghost Protocol (2011).mkv

Still, firecore does not find it. From my 40 movies only 10 are recognized while xbmc finds them all. On the other hand all of my 50 tv shows work fine.

(the share is mounted to be /Media at root)

I named it “mission.impossible.ghost.protocol.2011.720p.bluray.x264-sparks.mkv” and it works well:) if it doesn’t, try to reload metadata.

Reloading the metadata from the view of the mounted network drive did the trick! I was keep refreshing for changes in the settings > manage library view but that didn’t find my renamed files as it seems. Thanks a lot jakudo! You prevented me from switching back to xbmc :slight_smile:

[quote="jakudo"] I named it "mission.impossible.ghost.protocol.2011.720p.bluray.x264-sparks.mkv" and it works well:) if it doesn't, try to reload metadata. [/quote]


Just to confirm that this type of naming works well for mkv files, but for me the folder name is also important (I usually name it "[year] nameOfTheMovie (quality)" but in this case it has to be "[year] nameOfTheMovie" only.