Cannot download any subtitles

Subtitles cannot be anymore downloaded from Opensubtitles.
Every search on multiple languages, comes back with “none” as available subtitles.
Of course there are subtitles on the website itself.
There is no “connection error” or anything, as mentioned previously in similar threads.

Version is latest on ATV but I noticed this at least several weeks ago

Opensubtitles is accessible from my countjry and I download fine subtitles on my laptop.

Can you check the version of Infuse you are using by scrolling to the bottom of Infuse > Settings?

My app version is 7.7.1 (4749)

Would you be able to replicate this issue and send in a report from your device, and post the code it gives you here?

Code is 2P73S

You cant download any subtitle because of file name. Change it to “Reacher (2022) S02E03.mkv”

I don’t see any errors in your logs with regard to OpenSubtitles, and I had no trouble getting subtitles for that exact filename (on iOS, Apple TV, or Mac).

However, I do see you are using Emby so you will want to ensure the metadata fetcher you have enabled in Emby is including either an IMDb or TMDB ID number for these items. Without one of these IDs attached to a movie/series, Infuse will not be able to locate the correct subtitles on OpenSubtitles.

Edited, please ignore this post, as I was wrong, Emby HAS the IDs

That looks the reason, indeed. No one of the Emby titles - no movie, no series has IMDB, not TMDB ID.
Going manually, though, through thousands of these just to add IDs would be monumental task.
Can Infuse in case it does not have that ID default to a name search?

I'm using Emby just from this version to use the direct connection (which I'm just experimenting with so far, but looks promising), before that I was using an Infuse db through ftp and apparently either Infuse was searching well by name/episode or it was adding the ID itself in its own DB.

So, again - if the default search returns nothing (or Infuse sees that Emby provides no IMDB/TMDB ID), maybe either looks by name/episode or gets the ID first and then searches with it?
That I admit would be a patch, but would provide the functionality. On the other side, I'll enquire on Emby forums why TMDB is not attached in the database

You may consider switching the metadata provider used in Emby for TV shows to TMDB (this option can be found when using the Edit option for the Emby library). This would include the necessary info for Infuse to match these to titles on OpenSubtitles.

You can then use the Refresh Metadata option to update the info for the items in your library.

OK, I’ll need to add a correction of the my previous post, which I’ll remove.
Just some of the titles in Emby do not have the ID.
But that exact episode of Friends, which I tried above with the report above has IDs and still got no subtitles.

I submitted a new report, number is P7JWS

Episode of friends searched is S04.E23, titled “Friends.S04E23.1080p.BluRay.x264-TENEIGHTY”

Series have in Emby the correct IMDB ID - tt0583566 and TVDB ID - 303916

I think though that that may actually be a problem, as an opensubtitles search by that (correct) IMDB, returns… nothing?!?

I tried some other random series, like IMDB ID tt0551427 (Curb S01E06) - again nothing in Opensubtitles

Yes, that could be part of the reason as well. If something isn’t listed on OpenSubtitles then Infuse will not be able to access it.

OK,I think I got it now. However unlikely, for these episodes, subtitles don’t exist on
I was looking at the list of results and they are there, but is I click through, there are none - They say “removed”.
Also for that episode of Curb - same.

I guess the new is miles behind the old site and is indeed “commercial”

Maybe as a suggestion, we need to have a look at other subtitle sources?

Ok, to revive again, as this issue persists.
Frankly on several searched any search by IMDB ID in returns empty
Yet same searches - above sampled tt0583566 as an example, DO give results on the old interface
So the problem looks like in the new site.

Am I the only one with this highly annoying issue? Or maybe only Emby users are affected, as I didn’t have it while was using Infuse library over FTP?
Is there something to be done?
Can we either try searches by name and not IMDB ID, or search still .org site?