Cannot create 4.2.1 IPSW

Running windows xp.

Right clicking Create IPSW and selecting 4.2.1 

The process goes through downloading, unzipping, installing etc as usual but crashes at the same point every time: When it is downloading firmware signatures.

Looking in the seasonpass log I am seeing the same error “System.Collections.Generic.KeyNotFoundException” and “The given key was not present in thedictionary”


My complete log is here:


What is the reason for this fault? Does it indicate an issue with the aTV or the xp machine, or something else?




It appears to be a bug in the software. Do you have access to an alternate machine to try by any chance?

If you still receiving an error on a different machine I’d suggest opening a support ticket. It could be a bug related to the specific iOS version you’re trying to stitch:

Hi Matty

thanks for the response. Unfortunately I don’t have access to another machine.

The only other way forward (if this is a pre-requisite) would be for someone else to try on my behalf. I would be ok with sharing the blobs if this is something that is feasible.




i have s imilar problem with 4.4.4

i just did one and i just got a brand new i was trying it on…


it gets to downloading firmware signatures then tells me that an error has occured b/c of a conflicting program - i’ve shut down all my firewall and antivirus.


Can’t seem to figure it out… saves blobs and everything fine

i tried this trick with all older versions that give me trouble like u guys listed above, and hav hade a 99.9 percent sucesss rate



just change the ipsw to the one u guys have on ure apple tv

yeah i’ve also used that method with success but recently for 4.4.4 and 5.2 i’ve just been using seasonpass like normal and its been working fine…