Cannot Connect to ATV1 using FTP

I actually have 2 issues (also this is my first post sorry if I mess something up):

1 - I have been using aTV flash for about 6 months now and it has been great! I have transfered many videos to the aTV and all have played wonderfully. But, now for some reason I can no longer connect to my aTV via FTP. I have tried both Filezilla & Cyberduck niether would connect. I tried the IP number instead of AppleTV.local. No luck, I figured out that it was a DNS error and keep getting this message:

Connection attempt failed with "EAI_NONAME - Neither nodename nor servname provided, or not known:

I have tried flushing my DNS and still no luck. The aTV is connected to the network but via a wireless extender/repeater, could that be the problem? Does anyone know what I should do? I would also like to avoid having to wipe the aTV becaues of all the files I already have on there!

2 - I recently got an Ipad & Iphone 4. After messing around with them and installing Remote HD I finally got them to work…well most of the time. Some of the files that I play do not play at all on the aTV even though my device says they are. Others play the sound but I get no Picture. Also I have the HBO GO app and it has the Airplay option on it. When I try it again I get sound but no picture. Am I doing something wrong?

Thanks In advance for the help!

You may try re-installing aTV Flash 4.3.1 using a USB flash drive. The 4.3 and later versions include improved FTP and SSH components which should prevent problems like these in the future.