Cannot access Maintenance menu

I have the latest AppleTv update 1.1 installed and successfully installed ATVflash version 4.1.5. However, when I clicked on Maintenance in the AppleTV menu, all I get is a blank screen with the apple logo, and a short while later, the main menu will reappear. There is no way I can access the Maintenance menu.

I have restored the AppleTV to factory settings, and reinstalled ATVFlash with same result.

Any suggestions?

Thanks

I partially solved the problem this way:

  1. Restored AppleTV to factory default.
  2. Update to latest AppleTV software.
  3. Installed aTVFlash software (latest version just downloaded and installed in USB stick)
  4. On AppleTV main menu, went to NitoTV/Settings/InstallSoftware/Smart Installer. This downloaded a 10.4.9 update.
  5. Went back to NitoTV/Network, and my iMac is there as a mount.
  6. Selected it, and went to Create Manual Sharepoint. Entered usual parameters like SMB, user/password and the external hard disk on the iMac as the volume path.
  7. Clicked on Mount the volume and it mounted successfully.
  8. Saved the changes.
  9. Went to NitoTV/Network/Files and can see the mounted hard drive with the movies. Viewed a movie.
  10. Went back to NitoTV/Network and tried to mount the saved mount. Got huge error message on screen saying mount failed (I’ll copy the eror message later).
  11. Went back to NitoTV/Network/File, and the movies are still accessible!

What gives? I have repeated this twice and the result is always the same. The mount sharepoint will mount successfully first time but not subsequently, yet I could still see the movies listed. I want to add more sharepoints but am afraid I will completely lose the existing mounted sharepoint if I do so.

I must say, this aTVFlash software is a very difficult software to install and get right. No grandpa or grandma should buy it!

Regarding the hardware, I have a first generation AppleTV, a new 24" iMac running latest Snow Leopard, and for networking, I use an Apple Time Capsule. Encryption is WPA2.

I would appreciate any feedback on how to successfully mount a sharepoint each time. I have no problem connecting to iTunes and all its files and streaming. My problem is only with aTVFlash to connect to the external hard drive of the iMac.

I must say aTVFlash is a fantastic software for what it can do. Unfortunately, the setup to get things just right is not quite there yet. It requires too much technical knowledge to install and get it working.

Are you trying to mount the same network mount when it is already accessible through the nitoTV --> Files menu? This will actually not be necessary. The network mount will remain connected unless you unmount it or shut off the AppleTV.

Yes, I tried that as a test and got a very long error message on the screen. Is that normal?

 Getting the same message myself... trying to work around it... ill repost if I figure it out, I just bought an xServe, so I REALLY want to get this going

If the drive appears in the nitoTV --> Files menu it's already mounted - no need to mount it again.