Can’t add ”Mickey’s Trailer” to library

I have a weird problem when trying to add the Disney short film ”Mickeys Trailer (1938)”. I have the complete collection with all Disney shorts in a parent folder and all shorts are in separate folders named ”Moviename (year)”. All movies get added except Mickeys Trailer whose folder sits in the beginning of the list without showing any metadata. The parent folder is NOT added to any favourites so i browse it from the files section. I have tried everything i can think of to fix it: refreshing the metadata (the correct video is selected), using the file with or without an nfo file, deleting the nfo file, adding new nfo, making sure there is no header data in the file, redownloading the video in different formats, remuxing the videofile to a different resolution, deleting all metadata in Infuse and readding the entite library, changing the language from swedish to english in Infuse language settings etc etc.
The only way for me to get it to the correct place in the library is to just dump the videofile directly in the Disney parent folder. Then it shows but not all the data from imdb gets shown (plot is missing among others). So the files metadata is shown but it can’t be inside a subfolder…this one is difficult to explain…

Sorry, this is sort of done by design.

Infuse will ignore files which have the word ‘trailer’ in them, as these are often trailers of an actual movie which result in a lot of confusion in the library.

One way to get this working for now would be to rename the file to something like ‘Mickey’s Trail (1938)’ then use the edit option to select the correct ‘Mickey’s Trailer’ name manually.

It I had known this upfront my life would have had an extra day in it… That tip worked but it’s not pretty. I solved it with an alternate solution: used the swedish aka title both for the folder and the videofile. And then updated the folder to fix the sorting.
PS. Exkluding the word trailer by design is a bit clumpsy. Look the word up on imdb and you get a lot of hits…