Can someone please help me with this buffering issue?

No matter what I do, my movies buffer every 4-5 minutes.

Does anyone have any tips/advice on what to do about this? 

I am also having this problem.

What format are you using with your movies?  Are you hooked up to ethernet?  What are you using SMB, NFS or AFP?  

For me, I use a number of different files depending on what tv shows I find. Sometimes mkv, sometimes mp4 and sometimes .avi. Right now I am on .avi files, but i think the buffering was happening on other types, too. I am using ethernet via a belkin powerline adaptor system–it seems to work fine and is more stable than wireless. I believe I am using SMB–Windows 7 file sharing–is that what you mean? The buffering seems to have coincided within the last couple of maintenance updates of the media player.


Ditto except I am going wireless.

I dont really see the value in this product if we have to use cables…

And I agree regarding the updates…I have had buffering issues before but not every 3-5 minutes. I currently cannot watch movies.

Same issue. Plugged into a 1 Gb/s switch running under my house to a 1 Gb/s Linksys router that my Windows pc (where the files are shared) is plugged into (all CAT6 cables). Right after putting on aTV Flash things worked great with minimal buffering issues. Over time I have had more and more buffering issues. Does anyone know if there is a way to increase the buffer size and possibly delete whats in cache?

This product is close to useless and the company appears to have no interest in resolving this issue.

You are honestly better off converting all of your movies to mp4s and watching them through itunes.

And the balls on these guys to charge a yearly fee for something that doesnt (and really never has) completely worked?

It’s a network issue on your end. Streaming works fine on my setup, 10/100 ethernet to an SMB share on a Win7 box. I used to use Wifi (N) and streaming worked fine on that, but when friends came over and had their older cell phones connect to my network my router would swap to G (auto sensing as most new ones do) which limits your bandwidth. I ended up running a cable for $20 to avoid it. Wirless G is only 54MB/s under perfect conditions - no interference and excellent signal strength. Streaming a 720p or 1080p movie requires a lot of dedicated bandwidth.

How much traffic is going through your network? How many computers are using your Wifi? What’s your signal strength like? Wireless A/B/G/N? Is it password protected with WEP or WAP? How many other Wifi networks are near you? What channel are you on and what channel are they on?

There are a lot of factors that can contribute to poor signal and create buffering issues. You’d be surprised how much a 5Ghz cordless phone, a microwave, or a neighbors network on the same channel can mess with your Wifi speeds. You are not likely to notice this until you try to push a lot of data through your network like playing a high def movie that requires it. If you provide some insight into how you have your network setup someone can try to help you.

Thanks for your reply.

If it was a network issue, wouldnt I have similar issues playing movies through iTunes and/or Netflix??

I have no issues with either one.

As for traffic…the only thing I use wirelessly is an Ipad and I rarely have it on/drawing on wifi while im trying to watch a movie. I have one computer on my network, which is wired, my signal strength is at its highest but, I do live in a residential high rise in NYC and have quite a few other signals on my floor.


How do I check what channel I am on? I am using a Linksys WRT160n.

Maybe its time for me to get a newer, more powerful router?



The buffering issue may or may not happen with iTunes or Netflix because they use special video formats designed for being streamed, and your probably playing an MKV etc. off your shared drive.

To determine if it is a network issue, buy an ethernet cable and connect your AppleTV. If the issue still occurs, submit a bug report while it’s plugged in via ethernet. If it doesn’t, you know it’s network bandwidth that’s the problem.

When you connect to your Wifi there should be a details or properties you can view for each visible network. In there it should show what channel it’s on, check the ones nearest you, log into your router and swap channels to something not in use or with less people using if all 1-11 are taken. 1, 6, and 11 are the most common defaults for routers, so something other then those will probably work best (move two numbers away from busy channels if possible).


Jonez-I dloaded the inSSIDer utility and I am indeed smack in the middle of a whole bunch of noise/traffic, on channel 6. Also, my rssi was very low (-80’s).

Ive switched to channel 9; everyone else on my floor is (as you said) on 1, 6 or 11.

My rssi has jumped up to -35…will let you know if I experience any positive changes.

That should definitely help! Originally you were at ~20% signal strength and now you’re at ~65%. It should help, but you should try to get your signal to 80%+ if you still have buffering issues. If your router is behind furniture or tucked away move it so it’s unobstructed, move any metal objects that are near it away, and if you have multiple antennas make sure they are angled as recommended in the manual (they have them online if you don’t have the paper copy that came with it).

Let me know how it turns out!


Im confused…I thought the higher the number (the lower the negative) the better?

I am the reverse of what you said above; I was originally in the -80’s and now im in the -30’s.

So…ive tried a number of things: changing channels, changing bands and moving the router around.

No change.


Whats more is many times the ATV will just restart, right in the middle of a song. I fear this may be a software issue so ive decided to restore the ATV to its original settings to see if I still have the same problems playing songs, even with all of the Firecore stuff removed.

Will post my results.