Can no longer connect Emby (4.8 beta)

I’ve been using Infuse with Emby for a couple of years without issue. I was having trouble with some shows not refreshing so I decided to remove Emby from the server list and re-add it.

My Emby server shows up on the Add Media Server page. But when I enter my user name (and leave password blank as I don’t use passwords at home) I get:

Your username and password combination isn’t right. Please try again.

I tried a couple of different user names but got the same result.

I also tried using Emby Connect - once I enter the PIN into my server shows “Adrian has Authenticated” on the Apple TV. But Infuse still shows the “username and password combination isn’t right” message.

I also tried giving one of my users a password, restarted my emby server and still Infuse gives the same error.

(I’ve tried restarting everything - Emby, Infuse, even the whole Apple TV).

1 Like

If you can send in a report and post the code here, we can look into this.

Diagnostic code: 3WD67

Which version of Emby (server) are you running? beta

Seems this may be related a change in the Emby 4.8 beta(s).

It’s currently unclear if this is an Emby bug or something which requires a change in Infuse.

I tried installing the current release version ( of Emby on another PC and Infuse does connect successfully with that. Downgrading my main Emby server back to official is going to be painful (if not impossible).

Looks like more users will have issues with Infuse once Emby 4.8 migrates to official release.

I’m using beta and I have the same problem.

Obligatory caution about using beta software on primary devices…

With the point of betas being to spot issues before they go live to less adventurous users, hopefully you guys can report the issue (to Emby developers) so it gets fixed before the release goes official?


It doesn’t look like this issue was actually caused by the Emby beta - but by security changes.

I had changed the Allow this user to manage the server setting in Emby to remove admin from my user, but it appears that Infuse needs admin access (perhaps so it can trigger the install of the Infuse Sync plugin).

I rechecked the “Allow this user to manage the server” option and now I can successfully connect Infuse again.


This is helpful, thanks!

Infuse doesn’t (or at least didn’t) require admin access to use, so it seems this issue may only affect non-admin users.

This is something we’re looking into.


@james The Emby devs have posted their thoughts on this:


Blast my lack of a top-secret security clearance.

This is the content of the post on the Emby community forums:

The infuse client side code is trying to use an api that is now only allowed for admin users, which is getting the list of installed plugins on the server.

What the client code should do instead is remove the check, just assume that the plug-in is there, and be able to handle the 404 responses it will receive if it is not.


We’ve added a fix for this in the 7.5.7 update which is being submitted to Apple today.


Today’s 7.5.7 update resolves this issue when connecting to Emby 4.8.

Thanks for the feedback everyone! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.