Can I install ATV Flash 2.1 on apple software 5.2 ?

Hello

I have atv flash black 2.1 and my license has expired. 

Ive recently updated my apple tv2 to software 5.2

I wish to install my older version of atv flash 2.1 onto it, but i get an error.

Is this not able to be done without upgrading my firecore license to 2.2 also ?

This has come up before where people have problems installing ATV Flash without currently active support.   I believe if you raise a support ticker the issue gets resolved.   I am not sure what the solution will be as if you want to use the 5.2 firmware you NEED ATV Flash 2.2 to be compatible with that version of firmware.