Bug in aTV 3.6.1 - iPhone Remote app can cause crash

This crash is reproducible, but can be avoided.

The most recent version of the Remote app for iPhone/iPod Touch (v1.3), with the gestural control of Apple TV, is really, really cool. And even when aTV Flash is installed, it still works for the native Apple TV navigation (iTunes, Movie rentals, etc). But once you use Remote v1.3 to navigate into any aTV Flash applications of your Apple TV (Files, for instance), the Apple TV will crash and need a reboot, then will continue to crash on entering Files even when using the standard Apple TV remote. (Other applications such as XBMC still function after this crash.)

I know this because I’ve reproduced it twice - both times having to factory-restore the Apple TV, update to Apple TV 2.4, and re-patch aTV 3.6.1 in order to use the Files application. I’ve seen elsewhere in the forum that aTV Flash does not support Remote v1.3 yet, but it should be known that an attempt to navigate an aTV Flash application with Remote v1.3 will cause a crash only fixed with a restore.

So go ahead and use Remote v1.3 with your Apple TV because it is awesome, but only use it for Apple TV-native applications.

The more you know. (If I’m wrong about any of this, please correct me.)

Yes, not all aTV Flash plugins are compatible with the new Remote app. We should be rolling out a number of new plugin versions within the next 1-2 weeks that will be compatible with the Remote app.

A new version of ATVFiles was released, and is available through the Maintenance > Install Extras menu.

Same for me although I din’t do a restore/reinstall because it ATV Files worked again after reboot - until i tried to navigate with the remote app then it crashed again.

Does this release help with the Iphone?

Yes, the new ATVFiles and Jaman plugins (available through the Maintenance > Install Extras menu) are compatible with the iPhone remote app. More updates will be available soon.