Buffering with video

I am having some difficulty with buffering recently.

Current setup is a synology NAS streaming to 2 different Apple TV 4’s via netgear ORBI setup. My collection of DVD’s ripped as well as videos in 1080p have had no problem streaming to Infuse. Recently, I have decided to digitize my Bluray collection after finding out that DTS master audio and Dolby True HD could be passed through infuse. It was around this time I upgraded from Infuse 4 Pro and bought Infuse 5 Pro.

Initially I had no problems, having set up my Synology to share via SMB and playing the full lossless Bluray MKV on infuse, however recently I started to get the buffering spinning icon. After starting a video it will pause about 5-10 seconds in and buffer, and then will continue playing. It will then occasionally buffer (this started about 2-3x per movie), but over the past week it seems to do this about every 2-5 minutes and pauses for about 5 seconds.

I have since changed my synology shares to NFS (which seems to more quickly load the metadata), but some videos still seem to buffer. This only occurs on 1080p lossless mkv bluray rips and on my GoPro 4k videos.

So far I have tried changing to a wired connection (still had issues, and then found out that my Apple TV 4 has 100mb ethernet) so went back to wifi. On other devices I can confirm about 450mb connection via Orbi so I don’t think the wifi connection to Apple TV is the issue.

Is there something I am missing or does anyone else have any ideas to try? I love Infuse and the ability to have centralized lossless bluray is amazing, but not if I continually have buffering issues. Is there a chance this is a limitation of Infuse on my Apple TV 4 and I need to move up to Apple TV 4K? That would give me gigabit ethernet but I would think 450mb I am getting on my Orbi setup should be more than enough to run lossless bluray rip (and my GoPro 4k videos as well, obviously not in 4k on my device).

It sounds like it could be a network related issue, but a few users who have installed the upcoming tvOS 11.2.5 beta have said this update resolves some buffering issues they were seeing.

Alternatively, upgrading to an Apple TV 4K could improve things, as it includes Gigabit which makes a noticeable difference with load times. In our tests here, ~90GB 4K videos begin playing almost immediately without ever stopping to buffer.

I think you may be correct that it is a hardware issue. I decided to take my network out of the picture and move my NAS so it is only going through a switch and I still get the issue with the buffering. The part that has me scratching my head a bit is that my Samsung TV has no issues streaming the same content without buffering.

Is there anyone else who is using a Netgear Orbi router via wifi for streaming? I have no problem with upgrading to a new Apple TV 4k and placing my NAS on the same switch as the Apple TV 4k which will give me gigabit speeds and I should be able to then stream all of the video, but for my second and third rooms I would like to know if I upgrade to Apple TV 4k will I still be limited by my wifi speeds? The Netgear Orbi is about as fast as a mesh network as they now have, and my current house is a rental so I can’t do much to make ethernet runs to the other 2 locations of Apple TV currently. It may defeat the purpose of having a dedicated server if it’s only accessible at one location.

Now I am really confused. I was concerned this was a problem with my connection (specifically the netgear ORBI) which uses a wireless backhaul to connect between satellite and router. To take this out of the picture I have been going through the same satellite that the Apple TV 4 is connected to via wifi (since ATV4 only has 100mbps ethernet). After doing everything I could think of to troubleshoot the network, I randomly decided to stream lossless bluray mkv to my 2nd ATV4 in the bedroom and the stream plays flawless with no buffering. The 2nd Apple TV is actually further away from the satellite and no issues at all with streaming.

I still had the buffering issues on the main Apple TV 4 so did go ahead and put the beta onto that device and now I am back to streaming without buffering again. In fact, I have moved my NAS back to its home location, so my NAS -> router -> satellite -> 5g wifi to Apple TV and having no issues. The only difference between the 2 apple TVS is the one that had been buffering is 64gb and the one with no problems is 32gb.

I am not exactly sure what is going on at this point. All of this started happening when going from Infuse 4 to 5 which is why I thought there was an infuse issue. Now I am running NFS shares (had been running SMB2, but have tried DLNA, SMB2, 3, and NFS), and it seems that there could be an issue with the actual Apple TV device itself. Is there a buffer that Apple TV allows or does it self adjust. It is almost like the buffer under run is much smaller on that device?

At this point looking for any help or any ideas to confirm what is going on before going through the process of completely digitizing my collection of movies.

I’m also having a lot buffering problems with high bitrate content. When I try on the nvidia shield with Kodi everything streams perfectly (remux uhd bluray rips at 100mbps). Even 1080p remuxes seems to much to handle atm with infuse, buffering every minute. Both atv4k and nvidia shield are connected to my NAS via wifi (5ghz) and stream from the same share.

For the time being I’m switching back to Nvidia Shield. Hope this issue gets fixed soon, by apple or the infuse team, wherever the problem lies.

Checking in to voice that upgrading to the latest ATV4K beta software with 120MBPS speeds has NOT fixed the buffering issue. This is definitely a software bug- pre updating both Infuse and ATV4K i wasn’t having any issues as of 3 Infuse versions ago. I’ll probably go out and try a Shield to test if it plays back UHD content smoothly

Same problem here, have an ATV 4K, and it’s not my connection speed. But with 4K about an hour in the movie, it’s just start buffering. Then watch for a minute or 2 then buffering and buffering…

I also have severe buffering with ATV 4K when trying to stream UHD from my Synology NAS (ethernet solves it) . However, no buffering with 1080p sources.