Buffering with Infuse Pro and a NAS Qnap TVS-873e 4G

Hello,

I have some « buffering » while I watch movies in 4K.
All my movies are on my Qnap TVS-873e 4G, and I watch them with Infuse Pro on my Apple TV 4K. My ethernet network works with category 6 cables.
I have the same buffering problems with Qfile or Qvideo, only with some 4K movies (not all). HD movies plays well.
I also have buffering issues when I try to read 4K videos filmed with an iPhone XS Max. Even if these videos don’t last long (between 3 and 12 minutes only), it’s also buffering or the 4K video doesn’t even start.
I never have buffering problems when I read 1080p movies.
Infuse set up are : SMB Auto (I tried with Legacy, SMB 1, 2 or 3 and it’s even worse).
My Speed Test is 103,3 MB/s (write) and 109,9 MB/s (read). It seems like it’s not enough to play 4K movies in 2160p60.
What parameters do I have to change to read 4K files without any buffering ?
Thanks.

Raf

Welcome to the forum!

If you’re seeing the same issue in the QNAP apps, then it may be very possible that this particular device is not quite fast enough to stream these particular 4K videos. It could also be something as simple as a faulty ethernet cable which is downgrading your speed.

As a test, one thing you can try is connecting Infuse via SMB to a Mac or PC and try to stream the videos from there to see if you have better luck.

With regard to 4K videos shot on iOS, these have a few unique characteristics and the upcoming Infuse 6 release will add much better support for these (especially those with high fps).

  1. Make sure you are connected with a gigabit switch. 10/100 can’t cut it.
  2. On a wired PC run an iperf speed test to your NAS (you’ll have to install iperf on your NAS; google is your friend). This will go you raw network throughout between two wired devices
  3. It could be SMB performance sucks on your NAS. Try sharing your videos out through Plex media server installed on your NAS.

Hello,

The Qnap TVS-873e seems to be fast enough : quad-core AMD serie R RX-421BD 2,1 GHz (Turbo core > 3,4 GHz) + GPU Radeon™ R7 (for 4K reading).
My ethernet cable is equiped with category 6a cables.
I will try to stream from my MacMini as a test, thanks.

Hello,

  1. My switch is a Netgear GS 108 (GIGABIT ETHERNET - 8 auto-sensing 10/100/1000 Mbps Gigabit Ethernet ports with up to 10Gb non-blocking switching)
  2. I have Mac only. Is iperf available on Mac ?
  3. OK, i will try to install Plex Media Server on my Qnap and try to share videos from it.

Thanks !

Iperf3 is available for the Mac. It’s what I use at home (it’s not in the App Store as it’s a command line app). You’ll also need to install it on your NAS if it isn’t also pre installed. You should be able to install plex media server directly on your NAS.

Even CAT6 Ethernet cables can go bad. :wink:

Cat6 cables aren’t really going to give you an advantage for a simple home based network. All it does is eliminate crosstalk and other interference. You’ll really only see the advantage of running a giant bundle of cables through ceilings or if running 10Gig (which I wouldn’t recommend over cat6)

OK, thanks, I will try to do that.
Yesterday I have tried to put Infuse in FTP mode and it seems my movies in 4K are ok. But I just watched 10 minutes so I need to test it with a 4K movie of 2 hours. I also need to test it with iPhone XS Max movies in 4K which I couldn’t read at all (I don’t know why, because these films lasted less than 10 minutes… Very strange).
My ethernet home network is built with category 6a cables : is it ok ? I want to expand my network in my bedrooms : should I install category 7 cables or 6a are enough for the 10 years to come ?
Thanks again.

To address the Ethernet question, cat 6 is sufficient. I’m currently running cat 5e throughout the house (pre wired in construction) without a hitch.

I wasn’t trying to be funny when I said that even a cat 6 cable can go bad. They don’t always fail by completely not working, they can fail and still pass data, just very slowly. Temporarily replacing each of the suspect cables is a cheap and easy trouble shooting step.

I’m running cat 6a throughout the house. But all my cables go inside the walls and false ceilings. So I can’t change them so easily.

Do you think I need to install categroy 7 cables or Grade 3S cables ? Because I’m about to run some works in the rest of my appartment, and I would like to install RJ45 in my 3 bedrooms.

I wasn’t saying that you had to run the test cable through the ceilings and walls, just run them on the floor to test and if you find a bad one THEN you can narrow down which one you have to rerun.

If I didn’t already have Ethernet run I’d spend the money on the new wifi systems supporting mesh and ax when they get rolled out, not replacing cables.

I’m with bullseye. Run mesh Wi-Fi. Cat 7 is a waste of money unless you plan on running power over the cables (ie: Poe lighting). Cat 5e is usable for about 90% of applications.

Additionally Because this is happening in other apps I’d escalate this issue to QNAP

I will test my cables. I’m thinking about replacing cables from Apple TV 4K to my network and cable from my NAS to my switch Netgear GS 108 by category 7.
Currently, I’m using category 5e cables. And cables which are in my ceilings and wall are category 6a.