Buffering Videos

I’m having an issue when some 4k (x265) encoded MKV files will play fine for a few minutes and then buffer for 10-15 seconds, start up again and then start buffering again in a few more minutes.

Here is the specs…
iPad 4 - latest iPadOS
Infuse Pro 7.0.5 (3689)
This has an issue when on WiFi and wired via an USB C gigabit connection.

In order to eliminate the network as the issue, I also used the built in “download” feature and it still buffers at the same intervals as WiFi and wired.

It seems to happen on higher bitrate 4k files with high quality audio.

video #1 (10gig size - 1:48 length)
Video: HVC1 3840x1608 23.976fps [V: hevc main 10, yuv420p10le, 3840x1608 [default]]
Audio: AAC 48000Hz 8ch [A: English [eng] (aac lc, 48000 Hz, 7.1) [default]]
Audio: AAC 48000Hz stereo [A: Commentary 1 [eng] (aac he-aac, 48000 Hz, stereo)]
Audio: AAC 48000Hz stereo [A: Commentary 2 [eng] (aac he-aac, 48000 Hz, stereo)]

video #2 (17gig size - 1:58 length)
Video: HVC1 3840x1600 23.976fps [V: hevc main 10, yuv420p10le, 3840x1600 [default]]
Audio: TrueHD 48000Hz 8ch 9216kbps [A: English 7.1 (Dolby Atmos TrueHD) [eng] (truehd, 48000 Hz, 7.1, s24)]
Audio: Dolby AC3 48000Hz 6ch 640kbps [A: English (5.1) (Dolby Digital) [eng] (ac3, 48000 Hz, 5.1, 640 kb/s)]
Audio: Dolby AC3 48000Hz stereo 192kbps [A: Audio Commentary by Director Patrick Hughes
[eng] (ac3, 48000 Hz, stereo, 192 kb/s)]

video #3 (12gig - 1:27)
Video: HVC1 3840x1608 23.976fps [V: hevc main 10, yuv420p10le, 3840x1608 [default]]
Audio: AAC 48000Hz 8ch [A: English [eng] (aac lc, 48000 Hz, 7.1) [default]]

iPad Air 4?

Are those times minutes or hours? If hours those are not that high bitrate for 4K video. UHD Blu-rays are 50-100GB. Did you make these yourself or download them? Could be a problem with the source files.

Where are you saving these files and how are they connected to the router. Even if you iPad is wired if you drives are WiFi then you can still have issues. Did you try a speed test in infuse?

1 of them was created myself and the other 2 from my father in law.

They play fine on Kodi and Plex and MediaPlayerClassic.

The movie files reside on an Ubuntu server (latest and fully patched) and available via NFS mounts.

Speed test to that file reads about 12-15M

Okay sounds like you maybe have a network issue then. Plex is probably transcoding them. You should be getting 100 min for 4K to work. You are hardwired the whole path of just a part of it? Try using different Ethernet cables or routers/switches if you have them. If you have plex you can try connecting to that directly instead of nfs.

Can you confirm which iPad model you have?

Hardware decoding of HEVC (h.265) video is available on devices with the A9 chip (and later).

Older devices need to rely on software decoding which is less efficient so that may be contributing to the issues you are seeing on iPad.

If you’re creating these videos yourself, you can use h.264 instead of h.265 which will work better on older devices.

Sorry, meant to say iPad Air 4… only 3 months old…

So, I switched to SMB and it got a little better at 15-17M.

Still not good…

I switched to JellyFin and it magically jumped up to 800M.

Been seeing a lot of people with SMB/NFS issues besides me.

And here is the network configuration…

  • Unifi USG Pro
  • Unifi 16 port switch
  • Server into port 1
  • iPad into port 2
  • no changes to any of the speed tests.

Several people it has been updates to their servers that broke something.

Regardless, if you downloaded the files and still had issues then that’s odd. Are you sure you played the downloaded file?

Is everything on the same VLAN?

Just a flat network… nothing complicated.

Literally only difference is JellyFin at 800-900 vs NFS/SMB at 10-15.

And running thru an owncloud server on the same machine is 400M

Have you tried changing the SMB to either SMB 2 or “Legacy” in Infuse?

It might be your NFS export. Have you tried changing to either sync or async?

For reference I am getting 270 with NFS over Ethernet.