Buffering on 4K HVEC files since 5.8

Hey,

I’ve seen a couple of people mention playback issues since the 5.8 update but not specifically mentioning buffering so I’ll create this thread.

Since the 5.8 update, I don’t seem to be able to play 4K HVEC files without buffering. Now every couple of minutes, I get the spinning wheel on the screen. These are all files that I’ve played without issue before and the only change (that I can tell) was the Infuse update to v5.8.

The files themselves are direct playing and my server sits at only 15-20% usage while playing. Everything is connected through ethernet. I tried to clear some extra space on the hard drive thinking that would help but it didn’t make a difference.

Has anyone else had similar issues to this? Are there any suggestions?

Thanks.

3 Likes

im in the same situation here.
im also seeing buffering issues… i’ve tried SFTP and NFS access. but i still get buffering issues.

both on ethernet connection and on wifi connection (867 mbit phy) Channel utilization 10%. running VHT-80 channel 36. if i start speedtest im hitting 300mbit. on both wifi and on cable ethernet.

if i start playing a regular full hd… no problems.

1 Like

I too am having these issues. Mine isn’t with 4K video, but with HD videos of very high bitrate and large overall size. Nevertheless, it is quite a pain to begin watching something and then get a spinning wheel 1 minute later.

I know the files are not the issue, nor is my ethernet, as I can play them effortlessly on all of my MacOS devices.

Any ideas would be appreciated.

2 Likes

I just bought an Apple TV 4k, and picked up this app as a solution for streaming 4K videos. This happens to me a lot, as well. It seems to get better if I reboot the Apple TV. I had thought it may have been an issue with the Apple TV, but as other people are seeing this issue, it seems more likely that it has to do with the app not releasing memory / disk space usage properly in this version.

+1
Used infuse for many years. This is this first time I am having buffering issues. Tried legacy and auto smb setting and still issues. Same videos work fine with all other apps and in previous versions of infuse. Support diagnostic code: 23BA3

Please give today’s 5.8.2 update a try to see if it helps with what is going on.

Lots of little improvements included in this one. :wink:

Still having problems with very big files hdr 4K with 88 Bitrate… i tried on 2 apple TVs in different locations. Both just failed after a moment of spinning wheel with „error occurred loading content“
Works in plex after a long moment of caching.
Got streamed over plex via Internet
Debug code is 7namg

If I can help with testing any version on TestFlight, just send me a pm

I have been having buffering issues on my very large (20gb+) files. I have tried contacting support without much luck. Being a really old guy and slight technophobe, I threw some money at my 12 year old neighbour and her two friends who spent the last couple of evenings trying to solve my problem and were successful. It is what they discovered that has me a little perplexed. They tested setting up a small Infuse library on four separate & identical AppleTV 4K but with different configurations:

  1. SMB shares only
  2. SMB shares + Plex shares
  3. Plex shares only
  4. Tested setup 1-3 to make sure issues are reproduced on two separate machines.

The results per configuration:

  1. Regular buffering occurred in the large files (trying SMB 1, 2, legacy etc and accessing through both the library and files settings to see if that made any difference)
  2. Regular buffering for large files if added via SMB / No buffering if added via the Plex share
  3. No buffering
  4. Identical results as per above

My understanding is that the plex Integration just provides metadata and a file pathway so I am at a bit of a loss as to how this effects the way a file is played but evidently it does?! They test wired and wireless with a high speed netear nighawk gaming router

I will stick with setup 2 as it solves 99% of my issues, but it would still be good to have a solution in the event I need to play a large video located through a folders search rather than plex.

Hello

I’m also having this issue since upgrading to last version. Only on big mkv files.

I didn’t upgrade since the hdr black clippering was not resolve and now that i’ve done this upgrade i’m stuck with another problem (buffering).

Sorry but that’s a little annoying :frowning:

I’m available to troubleshoot the problem if needed.

Regards

I’m not 100% sure but it looks like The problem appear only on smb share not on upnp share… shoud it be a tvOS problem ?

My test is a remux mkv file of Pacific Rim 2 HEVC @69,3 Mbps.

Regards

It looks like upnp is really faster than smb ?

Is it planned to make it compatible with the library of Infuse in a future version ?

Have you tried the other levels of SMB like 1, 2, or legacy?

Thanks for your answer.

This must be configured on the SMB SHARE directly ?

If yes, my NAS did not give me the choice of SMB version unfortunately.

No. On the ATV when setting up/configuring the SMB share.

Mmm i’ve never seen this option, Have you got more informations how to find it ?

Settings - Shares - Select the saved share - Down the bottom of the favourites of the share you will see ‘edit share’ and then you can select the SMB version you want to use!

Look near the bottom of this users guide page under “Trouble Shooting” https://support.firecore.com/hc/en-us/articles/215090977-Streaming-From-Other-Devices

Many have found that “Legacy” works well but try each to see which setting best suits your setup.