Buffering issues on iPad - Release 6.5.3

Thanks @MissLiz

I’ve done some tests on my side as well, I don’t get as much transfer speed through wifi on my side but can definitely see a difference between my iPad and iPhone/Apple TV. I didn’t go in as much details and don’t have the information about previous versions of Infuse.

Your 4K file obviously kept buffering almost every second for me on any platform, my 1080p file did buffer only on my iPad as it didn’t need as much bandwith but I only seem to get half the bandwith on ipadOS vs iOS/tvOS

Also I can tell I could get more as when downloading the file I’m above 10mb/s

Really good info in your post, just one more question. The last group of releases of Infuse have also been close to Apple OS releases including the recent 14.2 version. Could you also state which Apple OS version you’re using with the tests your ran? Did you have the 14.0, 14.1, or 14.2 for these tests and for others?

It may not have any bearing but it may help duplicate the problem.

Thanks @Bonbaroms

Very interesting…

I also have an Apple TV 4K, and I’ve just done the same test again with WIFI on that (normally I use a wired connection.)

So same test with Apple TV 4K WIFI … Play 3 mins, Pause 2 mins, Play, Pause, Stop
TV OS 14.0.2

My 4K videos play back fine on Apple TV and the graph shows the same kind of results that I got on the iPad prior to the 6.5.3 Infuse update.
I’m still concerned that the data transfer drops in pause mode though, and that the maximum transfer speed is only 15 MBytes/sec. These in conjunction mean even in this “working” case, the streaming cache is not working, because it never transfers data faster than the video bitrate.
I can’t do this test on my iPhone, because it’s just too old, and won’t playback h265 video at all.

So, anyway, it looks to me as has been said previously, that the buffering problem is iPad specific.

@NC_Bullseye
The original pre-6.5.3 test I mentioned above was done around 6th September. I can’t definitely say which OS version point release I was using then, but I guess it must have been OS 13.

The test I did today was using OS 14.2

Thanks

Liz

@MissLiz; I’m experiencing the same problems on my Apple TV, maybe I misunderstood you but it’s definitely not an iPad-only issue.

@Solaar
No, you didn’t misunderstand.
For me it’s still playing back fine on the Apple TV 4K with WI-FI.
Do you have the Apple TV 4K, or an earlier version?

I see @Mr-K mentioned above that it worked on his Apple TV 4K, but not on his Apple TV 4th gen HD.

Is it possible this only affects iPad and certain versions of the Apple TV?

Liz

Sorry if this has been asked before, but do you plenty of free space on your device(s)? Maybe caching is slower depending on that. Just a thought.

This is not a free space issue. I have 400GB free on my iPad.
This is a change that happened specifically after upgrading to 6.5.3

Liz

4 posts were split to a new topic: Slow speeds on Apple TV

Thanks for the feedback, everyone.

We believe we’ve tracked down what’s causing this, and are working to have a fix available soon in the 6.5.4 update.

3 Likes

Thanks! Just a question, how do I know when there’s a new tvOS version ready for update?

Often James will post in threads like this when a remedy has been addressed and the release is either just released or imminent.

You can also keep an eye on the release page for updates that happen at the time of release.

EDIT TO ADD: you can also turn on automatic updates for apps in the ATV settings and as soon as they are available on the update servers that handle you’re area they will be installed.

1 Like

Hello,

I meet the same problem with my Apple TV 4K, Infuse buffering with many of my 4k MKV files. Do you think that the problem you explain here is the same? Before I nerver have this with all my files (1080p mkv ou 4k mkv), some files have 50Go size and other less. I use a synology NAS, and i made a test with a SMB3 and NFS share and the issue is the same.

Thank you for your help.

Stephan

Welcome to the forum!

Not sure if it could be related but as James said above there is a new release of Infuse coming soon (just a guess on my part but I’d look for it by Mon or Tues of next week but that’s just a GUESS).

If it doesn’t fix your problem you probably should start a new thread with some specific details since this one is targeting the iPad version and that may confuse some things.

Infuse 6.5.4, which includes a handful of fixes for Wi-Fi streaming, is now rolling out on the App Store.

Please give it a try and let us know how things go. :slight_smile:

1 Like

Hi, thanks for tour feedback, i will try this new version with my Apple TV 4K. Please note that I use the Ethernet connection for a best result, and before all works perfectly. I can try to do a default reset of my Apple TV 4K, Perhaps it will be better.

I come back here to tell you if it’s good.

Thank’s

Stephan

Thanks @james

While 6.5.4 is a definite improvement for me over 6.5.3, playback on my iPad, it is still not as good as it was pre 6.5.3

What I am now experiencing with my 15 MBytes/sec videos playing from my NAS is:

  1. Start playback
  2. After 6 seconds of buffering, playback begins (which is fine and expected)
  3. Video plays back for 7 seconds, video stops and buffers again (not good!)
  4. After 6 further seconds of buffering, playback begins again, and this time video plays to end.

Note, that the above is 100% repeatable on my setup.

So a definite improvement, as it doesn’t continually buffer all the way through the video anymore, but why the extra buffering at the start?

Please take a look at this data transfer graph from my NAS which I think explains this.

The graph shows again the transfer rate from my NAS during Infuse playback. Comparing to my previous graphs posted here, the difference is clear. For the first 30 seconds or so of playback, the data transfer rate is too low to playback the video without buffering, which then causes the extra buffering that I am seeing at the start.

Now please take a look at this graph:

So, this graph shows that my WI-FI speed from my NAS allows for a 40 MBytes/sec transfer to my Mac, and about 30MBytes/sec to my iPad.
This graph clearly shows that Infuse is not utilising all the WIFI bandwidth that is available.
This is also why the Streaming Cached “auto” mode doesn’t work for me, because Infuse is only using a small fraction of the WIFI bandwidth that is available, and never transfers data faster than the video bitrate. Why is this?

I hope this information helps diagnose this issue.

Thanks

Liz

1 Like

@james @NC_Bullseye
This issue has not been resolved (at least not completely)
Can the solved state be removed?

Thanks

Liz

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.