Buffering issues on iPad - Release 6.5.3

D6VEH, same problem still.


Apologies for this long message, but I have quite a lot to say here, so please stick with me! :slight_smile:

I also have the same issue since the latest update to Infuse with some of my videos. I get buffering after about 10 seconds of video playback on some of my videos. It occurs in both auto and legacy streaming cache modes. This is on an iPad Pro 2019, streaming via a Synology NAS SMB share (although I don’t think this is relevant to the issue… more later)
I have an on-going support request that I originally raised around 3 months ago with Firecore. Essentially, I have some high bit-rate videos that would play back perfectly 99% of the time on the iPad, but I would get the very occasional buffering issue. I could watch for hours without this occurring!
I’ve checked the same videos with the latest version of Infuse, and they now buffer every 10 seconds or so, and so are now completely unwatchable. This is 100% consistent.

Now, these videos are around 15 MBytes / sec. To play these, you need decent WIFI. In my case I upgraded to an Archer AR2800 router about a year ago, which allows me to transfer data at more than 30 MBytes/sec (my previous Sky Router just didn’t cut it, and could only transfer WIFI data at around 10 MBytes/sec, not enough to play 15M Bytes/sec videos).

Anyway I did some analysis a month or so ago with the previous version of Infuse, and now I’ve done that again with the latest version of Infuse for comparison. What I did was play a test video, and check what the data transfer rate was from my NAS during play/pause.
No other devices were using the WIFI while I ran my tests.
So I have 2 graphs from my NAS, which I have attached here, one from before, and 1 after the Infuse update.

Points of note (remember, video = 15M Bytes/sec, available WIFI bandwidth > 30 MB/sec in my case):


  1. During normal playback, the video data transfers from the NAS at around 15 MBytes/sec, enough for playback but NOT enough to buffer ahead. The cache bar does NOT fill up.
  2. During pause, the video transfer rate drops to around 8 MBytes/sec. Well below the video bit rate.
  3. Data transfer peaks at around 20 MBytes/sec
    Because the video never caches ahead during playback, I believe that was why I was seeing the occasional buffering. A momentary drop in WIFI performance would be enough to cause it.

Fast forward to today:
Infuse _streaming_after_update.png

  1. During normal playback, the video data transfers from the NAS at around 8 MBytes/sec, nowhere near enough for video playback. This seems to be the direct cause of the buffering after 10 seconds of playback.
  2. During pause, the video transfer rate drops to around 4 MBytes/sec. Well below the video bit rate, and about half of what I was seeing in the previous version of Infuse.
  3. Data transfer peaks at around 11 MBytes/sec.

It is my theory that Infuse is clamping the maximum WIFI data transfer rate, and the maximum value (which was already too low) has been essentially halved with the new version of Infuse. I believe this will also affect lower bitrate videos too, but the problem will obviously be much worse for higher bitrates.
If my theory is correct, I would really like to see an option in Infuse, so that the user can decide what to set this to because the value was already too low in the previous version of Infuse.

If anyone is interesting in testing my video on their setup, I have uploaded a 1 minute clip to drop box which you can download here:

Dropbox link

This is a 1 min, 4K hevc video.

Thanks for you help



Thanks @MissLiz

I’ve done some tests on my side as well, I don’t get as much transfer speed through wifi on my side but can definitely see a difference between my iPad and iPhone/Apple TV. I didn’t go in as much details and don’t have the information about previous versions of Infuse.

Your 4K file obviously kept buffering almost every second for me on any platform, my 1080p file did buffer only on my iPad as it didn’t need as much bandwith but I only seem to get half the bandwith on ipadOS vs iOS/tvOS

Also I can tell I could get more as when downloading the file I’m above 10mb/s

Really good info in your post, just one more question. The last group of releases of Infuse have also been close to Apple OS releases including the recent 14.2 version. Could you also state which Apple OS version you’re using with the tests your ran? Did you have the 14.0, 14.1, or 14.2 for these tests and for others?

It may not have any bearing but it may help duplicate the problem.

Thanks @Bonbaroms

Very interesting…

I also have an Apple TV 4K, and I’ve just done the same test again with WIFI on that (normally I use a wired connection.)

So same test with Apple TV 4K WIFI … Play 3 mins, Pause 2 mins, Play, Pause, Stop
TV OS 14.0.2

My 4K videos play back fine on Apple TV and the graph shows the same kind of results that I got on the iPad prior to the 6.5.3 Infuse update.
I’m still concerned that the data transfer drops in pause mode though, and that the maximum transfer speed is only 15 MBytes/sec. These in conjunction mean even in this “working” case, the streaming cache is not working, because it never transfers data faster than the video bitrate.
I can’t do this test on my iPhone, because it’s just too old, and won’t playback h265 video at all.

So, anyway, it looks to me as has been said previously, that the buffering problem is iPad specific.

The original pre-6.5.3 test I mentioned above was done around 6th September. I can’t definitely say which OS version point release I was using then, but I guess it must have been OS 13.

The test I did today was using OS 14.2



@MissLiz; I’m experiencing the same problems on my Apple TV, maybe I misunderstood you but it’s definitely not an iPad-only issue.

No, you didn’t misunderstand.
For me it’s still playing back fine on the Apple TV 4K with WI-FI.
Do you have the Apple TV 4K, or an earlier version?

I see @Mr-K mentioned above that it worked on his Apple TV 4K, but not on his Apple TV 4th gen HD.

Is it possible this only affects iPad and certain versions of the Apple TV?


Sorry if this has been asked before, but do you plenty of free space on your device(s)? Maybe caching is slower depending on that. Just a thought.

This is not a free space issue. I have 400GB free on my iPad.
This is a change that happened specifically after upgrading to 6.5.3


4 posts were split to a new topic: Slow speeds on Apple TV

Thanks for the feedback, everyone.

We believe we’ve tracked down what’s causing this, and are working to have a fix available soon in the 6.5.4 update.


Thanks! Just a question, how do I know when there’s a new tvOS version ready for update?

Often James will post in threads like this when a remedy has been addressed and the release is either just released or imminent.

You can also keep an eye on the release page for updates that happen at the time of release.

EDIT TO ADD: you can also turn on automatic updates for apps in the ATV settings and as soon as they are available on the update servers that handle you’re area they will be installed.

1 Like


I meet the same problem with my Apple TV 4K, Infuse buffering with many of my 4k MKV files. Do you think that the problem you explain here is the same? Before I nerver have this with all my files (1080p mkv ou 4k mkv), some files have 50Go size and other less. I use a synology NAS, and i made a test with a SMB3 and NFS share and the issue is the same.

Thank you for your help.


Welcome to the forum!

Not sure if it could be related but as James said above there is a new release of Infuse coming soon (just a guess on my part but I’d look for it by Mon or Tues of next week but that’s just a GUESS).

If it doesn’t fix your problem you probably should start a new thread with some specific details since this one is targeting the iPad version and that may confuse some things.

Infuse 6.5.4, which includes a handful of fixes for Wi-Fi streaming, is now rolling out on the App Store.

Please give it a try and let us know how things go. :slight_smile:

1 Like

Hi, thanks for tour feedback, i will try this new version with my Apple TV 4K. Please note that I use the Ethernet connection for a best result, and before all works perfectly. I can try to do a default reset of my Apple TV 4K, Perhaps it will be better.

I come back here to tell you if it’s good.



Thanks @james

While 6.5.4 is a definite improvement for me over 6.5.3, playback on my iPad, it is still not as good as it was pre 6.5.3

What I am now experiencing with my 15 MBytes/sec videos playing from my NAS is:

  1. Start playback
  2. After 6 seconds of buffering, playback begins (which is fine and expected)
  3. Video plays back for 7 seconds, video stops and buffers again (not good!)
  4. After 6 further seconds of buffering, playback begins again, and this time video plays to end.

Note, that the above is 100% repeatable on my setup.

So a definite improvement, as it doesn’t continually buffer all the way through the video anymore, but why the extra buffering at the start?

Please take a look at this data transfer graph from my NAS which I think explains this.

The graph shows again the transfer rate from my NAS during Infuse playback. Comparing to my previous graphs posted here, the difference is clear. For the first 30 seconds or so of playback, the data transfer rate is too low to playback the video without buffering, which then causes the extra buffering that I am seeing at the start.

Now please take a look at this graph:

So, this graph shows that my WI-FI speed from my NAS allows for a 40 MBytes/sec transfer to my Mac, and about 30MBytes/sec to my iPad.
This graph clearly shows that Infuse is not utilising all the WIFI bandwidth that is available.
This is also why the Streaming Cached “auto” mode doesn’t work for me, because Infuse is only using a small fraction of the WIFI bandwidth that is available, and never transfers data faster than the video bitrate. Why is this?

I hope this information helps diagnose this issue.



1 Like

@james @NC_Bullseye
This issue has not been resolved (at least not completely)
Can the solved state be removed?



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.