Buffering issues on iPad - Release 6.5.3

I’m having buffering issues on my iPad only since the last update 6.5.3. I had no issues prior to the new release.

Buffering issue is only happening on my iPad (iPad Pro 11 2018), not on my iPhone (iPhone Pro 12, 2020) or Apple TV (HD 2015).

I’m loading videos from a Synology NAS on my local network and it buffers at least 10 times through a 40mins videos while it didn’t buffer a single time prior to the latest release for the same video

What do you have the Streaming Cache set on in the iPad Infuse settings?

It’s set to “Auto”

I’m trying now with “Legacy”, what’s the difference between the two ?

Auto will attempt to buffer the entire video when started where the Legacy will buffer smaller chunks.

It’s an easy test that helps on some buffering issues.

Same issue with both cache options

The next thing I’d suggest is to do a speed test from within Infuse to the same file from all three devices and see if the iPad shows the same rate.

Are all three on WiFi or is the ATV on Ethernet?

All three are on Wi-Fi, how can I do my speedtest within infuse ?

I’ll do those tests this evening

I tried multiple tests on my side but I can’t find a reason for my iPad to have those buffering issues.

I’ve plenty of storage left on the iPad, no issue on other streaming apps even with 4K youtube videos, Synology, Network and iPad were restarted.

I didn’t have a single issue before this last upgrade

Maybe try the just released OS 14.2 and see if any issues. I know people with problems on older iOS versions

Issue still present after update to 14.2

Is this affecting all videos or just a few?

How are you connecting to your Synology?

The latest release of Infuse Pro 6 has been buffering like crazy movie files that weren’t a problem before. I don’t see a common denominator from my files, my apple tv is a 4th gen HD, yet i have a Apple TV 4k in another room, that one seems to not been having issues with the files my HD one is.

I’ve seen a couple of posts where others mention pretty much the same issue.

I have the same problem. I was watching a movie yesterday evening with no buffering or problems. I took a pause midway and decided to start watching again tonight. However I discovered there was an update both to iOS and Infuse so ran both first. Now most movies are unwatchable due to buffering and the very same movie that worked fine yesterday now freezes or buffers every minute or so.

If you see this again, please send in a report so we can investigate further.

iOS: Settings > Email Us

Apple TV: Settings > Submit Diagnostics

Simply post the 5 digit code here.

I’m connecting through SMB on my local network

MKV files 1080P Dolby Digital Plus, x264 ~4.5GB

No issues before with same files and still no issue on Apple TV and iPhone. Only the iPad is getting me error.
They are all connected through wifi at equal distance with the same users when doing my tests, I can even stream on the iPhone and Apple TV at the same time without buffering issue but iPad alone keeps buffering every ~3mins

Diagnostics: HTTS8

Just curious, what do you have the “Streaming Cache” set to on the iPad and second, have you checked to see what other apps may be using background app refreshing in the iPad settings? I’ve seen what appears to be other apps do a refresh when Infuse is playing and that may be taking too much horsepower from the playback. That’s just a guess though.

I’ve tried both cache options as you mentioned in the earlier post

Just removed all apps in background and still same issue

Okay, it was just shot in the dark. I’m sure once James has a chance to review the diagnostics he’ll chime back in. :wink:

1 Like

D6VEH, same problem still.


Apologies for this long message, but I have quite a lot to say here, so please stick with me! :slight_smile:

I also have the same issue since the latest update to Infuse with some of my videos. I get buffering after about 10 seconds of video playback on some of my videos. It occurs in both auto and legacy streaming cache modes. This is on an iPad Pro 2019, streaming via a Synology NAS SMB share (although I don’t think this is relevant to the issue… more later)
I have an on-going support request that I originally raised around 3 months ago with Firecore. Essentially, I have some high bit-rate videos that would play back perfectly 99% of the time on the iPad, but I would get the very occasional buffering issue. I could watch for hours without this occurring!
I’ve checked the same videos with the latest version of Infuse, and they now buffer every 10 seconds or so, and so are now completely unwatchable. This is 100% consistent.

Now, these videos are around 15 MBytes / sec. To play these, you need decent WIFI. In my case I upgraded to an Archer AR2800 router about a year ago, which allows me to transfer data at more than 30 MBytes/sec (my previous Sky Router just didn’t cut it, and could only transfer WIFI data at around 10 MBytes/sec, not enough to play 15M Bytes/sec videos).

Anyway I did some analysis a month or so ago with the previous version of Infuse, and now I’ve done that again with the latest version of Infuse for comparison. What I did was play a test video, and check what the data transfer rate was from my NAS during play/pause.
No other devices were using the WIFI while I ran my tests.
So I have 2 graphs from my NAS, which I have attached here, one from before, and 1 after the Infuse update.

Points of note (remember, video = 15M Bytes/sec, available WIFI bandwidth > 30 MB/sec in my case):


  1. During normal playback, the video data transfers from the NAS at around 15 MBytes/sec, enough for playback but NOT enough to buffer ahead. The cache bar does NOT fill up.
  2. During pause, the video transfer rate drops to around 8 MBytes/sec. Well below the video bit rate.
  3. Data transfer peaks at around 20 MBytes/sec
    Because the video never caches ahead during playback, I believe that was why I was seeing the occasional buffering. A momentary drop in WIFI performance would be enough to cause it.

Fast forward to today:
Infuse _streaming_after_update.png

  1. During normal playback, the video data transfers from the NAS at around 8 MBytes/sec, nowhere near enough for video playback. This seems to be the direct cause of the buffering after 10 seconds of playback.
  2. During pause, the video transfer rate drops to around 4 MBytes/sec. Well below the video bit rate, and about half of what I was seeing in the previous version of Infuse.
  3. Data transfer peaks at around 11 MBytes/sec.

It is my theory that Infuse is clamping the maximum WIFI data transfer rate, and the maximum value (which was already too low) has been essentially halved with the new version of Infuse. I believe this will also affect lower bitrate videos too, but the problem will obviously be much worse for higher bitrates.
If my theory is correct, I would really like to see an option in Infuse, so that the user can decide what to set this to because the value was already too low in the previous version of Infuse.

If anyone is interesting in testing my video on their setup, I have uploaded a 1 minute clip to drop box which you can download here:

Dropbox link

This is a 1 min, 4K hevc video.

Thanks for you help