Buffering HEVC 4K video


I purchased Infuse to use it on my Apple TV 4K.

I am trying to read a 4K movie (HEVC format) on external usb hardrive connected to my internet box.

My Apple TV is connected to my internet box using wifi (debit 216 mb/s).

When I try to read the video from the apple tv I have always a buffering after 3 min of playing and after the movie still buffering again and again.

I tried to look on the forum what could be the issue and I changed SMB settings but no improvement.

I have no workgroup with username and password set up.

I can’t figure out what’s wrong and I hope you could help me understanding.

Thank you

Welcome to the forum!

Would it be possible to temporarily as a test, connect your ATV to the router with an Ethernet cable?

I need to find an Ethernet câble quite long (10 m) but I will try to find one at work.

Thank you

Does the router have a gigabit Ethernet port? You might have to do a web search for the model number if you don’t have the specs handy.

We also have a number of SMB related improvements in progress, and plan to have these available out in the next release (6.0.3).

Additionally, with this release, you will have the option to build up a larger buffer by pausing the video for a few moments. Between these two changes, there’s a good chance you may be able to stream 4K video over Wi-Fi.

We have the SMB related improvements now available for beta testing via TestFlight.

If you’re interested in trying a beta build of 6.0.3, drop me a note and I can get you set up.


I succeeded in having a 10m rj45 câble :slight_smile:

No buffer at all.

Does it mean that it is my WiFi if 210 mb/s which is causing buffering problem ?

Thank you

Great! :slight_smile:

Ethernet will almost always be faster, but the changes in 6.0.3 should help speed things up with Wi-Fi too.

Great in finding the cable not having it in the middle of my living room :slight_smile:

Would be interested in trying the release 6.0.3 to see if I can use my WiFi.

Thanks for your reply James

I know you said you changed the SMB settings but did you try the “Legacy” SMB setting?

Also you may want to see if your router has a priority setting for streaming. Sometimes that will help eliminate buffering.

210Mbps is low for 4K video. I’d look at upgrading your wifi if you want to do wireless streaming.